summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElfyn McBratney <beu@gentoo.org>2005-05-09 14:44:25 +0000
committerElfyn McBratney <beu@gentoo.org>2005-05-09 14:44:25 +0000
commit5ba95de03e566e3bb17668048f17c0e17bb103ea (patch)
tree1f0becb37d983fc86bf59d234569cf74877afadf /dev-libs/apr/apr-0.9.6-r3.ebuild
parentVersion bumped. Requested by Choe Hwanjin ;) This closes bug #91844. (diff)
downloadhistorical-5ba95de03e566e3bb17668048f17c0e17bb103ea.tar.gz
historical-5ba95de03e566e3bb17668048f17c0e17bb103ea.tar.bz2
historical-5ba95de03e566e3bb17668048f17c0e17bb103ea.zip
Rev bumps that remove LFS support from APR.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'dev-libs/apr/apr-0.9.6-r3.ebuild')
-rw-r--r--dev-libs/apr/apr-0.9.6-r3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/apr/apr-0.9.6-r3.ebuild b/dev-libs/apr/apr-0.9.6-r3.ebuild
new file mode 100644
index 000000000000..80d0c48dccdc
--- /dev/null
+++ b/dev-libs/apr/apr-0.9.6-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr/apr-0.9.6-r3.ebuild,v 1.1 2005/05/09 14:44:25 beu Exp $
+
+inherit flag-o-matic libtool
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ipv6"
+RESTRICT="test"
+
+DEPEND=""
+
+src_compile() {
+ elibtoolize || die "elibtoolize failed"
+
+ myconf="--datadir=/usr/share/apr-0"
+
+ myconf="${myconf} $(use_enable ipv6)"
+ myconf="${myconf} --enable-threads"
+ myconf="${myconf} --enable-nonportable-atomics"
+ myconf="${myconf} --with-devrandom=/dev/random"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" installbuilddir=/usr/share/apr-0/build install || die
+
+ # bogus values pointing at /var/tmp/portage
+ sed -i -e 's:APR_SOURCE_DIR=.*:APR_SOURCE_DIR=/usr/share/apr-0:g' ${D}/usr/bin/apr-config
+ sed -i -e 's:APR_BUILD_DIR=.*:APR_BUILD_DIR=/usr/share/apr-0/build:g' ${D}/usr/bin/apr-config
+
+ sed -i -e 's:apr_builddir=.*:apr_builddir=/usr/share/apr-0/build:g' ${D}/usr/share/apr-0/build/apr_rules.mk
+ sed -i -e 's:apr_builders=.*:apr_builders=/usr/share/apr-0/build:g' ${D}/usr/share/apr-0/build/apr_rules.mk
+
+ cp -p build/*.awk ${D}/usr/share/apr-0/build
+ cp -p build/*.sh ${D}/usr/share/apr-0/build
+ cp -p build/*.pl ${D}/usr/share/apr-0/build
+
+ dodoc CHANGES LICENSE NOTICE
+}