summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-03-09 20:05:23 +0000
committerTorsten Veller <tove@gentoo.org>2011-03-09 20:05:23 +0000
commit156ce434137c013a522d472f01e7acccf8e7e594 (patch)
tree6c094b1cc0867d14e6b1a7a3eba20eaef2ad0296 /dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild
parentVersion bump, simplified the EAPI4 and a small change in the elog to install ... (diff)
downloadhistorical-156ce434137c013a522d472f01e7acccf8e7e594.tar.gz
historical-156ce434137c013a522d472f01e7acccf8e7e594.tar.bz2
historical-156ce434137c013a522d472f01e7acccf8e7e594.zip
Move perl modules to vendor_dir (#295895)
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild')
-rw-r--r--dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild b/dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild
new file mode 100644
index 000000000000..d4ed6770d0f6
--- /dev/null
+++ b/dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/clearsilver/clearsilver-0.10.5-r1.ebuild,v 1.1 2011/03/09 20:05:23 tove Exp $
+
+# Please note: apache, java, mono and ruby support disabled for now.
+# Fill a bug if you need it.
+#
+# dju@gentoo.org, 4th July 2005
+
+inherit eutils perl-app multilib autotools
+
+DESCRIPTION="Clearsilver is a fast, powerful, and language-neutral HTML template system."
+HOMEPAGE="http://www.clearsilver.net/"
+SRC_URI="http://www.clearsilver.net/downloads/${P}.tar.gz"
+
+LICENSE="CS-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="perl python zlib"
+
+DEPEND="python? ( dev-lang/python )
+ perl? ( dev-lang/perl )
+ zlib? ( sys-libs/zlib )"
+
+DOCS="README INSTALL"
+
+if use python ; then
+ DOCS="${DOCS} README.python"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-perl_installdir.patch
+
+ use zlib && epatch "${FILESDIR}"/${P}-libz.patch
+
+ epatch "${FILESDIR}"/${P}-libdir.patch
+ sed -i -e "s:GENTOO_LIBDIR:$(get_libdir):" configure.in
+ eautoreconf || die "eautoreconf failed"
+
+ # Fix for Gentoo/Freebsd
+ [[ "${ARCH}" == FreeBSD ]] && touch ${S}/features.h ${S}/cgi/features.h
+}
+
+src_compile() {
+ econf \
+ $(use_enable perl) \
+ $(use_with perl perl /usr/bin/perl) \
+ $(use_enable python) \
+ $(use_with python python /usr/bin/python) \
+ $(use_enable zlib compression) \
+ "--disable-apache" \
+ "--disable-ruby" \
+ "--disable-java" \
+ "--disable-csharp" \
+ || die "./configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ${DOCS} || die "dodoc failed"
+
+ if use perl ; then
+ fixlocalpod || die "fixlocalpod failed"
+ fi
+}