summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-09-15 23:20:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-09-15 23:20:47 +0000
commit46c140281ec09921ce5ce706c5489ce9e8e9b26f (patch)
treeea8d45a808c8188cafe21c80e478018b9c1b0620 /dev-libs/libbase58/libbase58-0.1.0.ebuild
parentAdd a patch to fix parallel build issue #517916 (diff)
downloadhistorical-46c140281ec09921ce5ce706c5489ce9e8e9b26f.tar.gz
historical-46c140281ec09921ce5ce706c5489ce9e8e9b26f.tar.bz2
historical-46c140281ec09921ce5ce706c5489ce9e8e9b26f.zip
Initial commited, needed for bfgminer-4.8 and above
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xF52D4BBA
Diffstat (limited to 'dev-libs/libbase58/libbase58-0.1.0.ebuild')
-rw-r--r--dev-libs/libbase58/libbase58-0.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/libbase58/libbase58-0.1.0.ebuild b/dev-libs/libbase58/libbase58-0.1.0.ebuild
new file mode 100644
index 000000000000..f75a291e36d5
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbase58/libbase58-0.1.0.ebuild,v 1.1 2014/09/15 23:20:35 blueness Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable tools tool)
+ )
+ autotools-utils_src_configure
+}