summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-11-30 04:12:53 +0000
committerTim Harder <radhermit@gentoo.org>2013-11-30 04:12:53 +0000
commit5edf68953258a1b04307b549546b27c1e5df2075 (patch)
tree7d846ee426448bcb8439886de0597292b493ea87 /dev-libs/libexplain/libexplain-1.3.ebuild
parentSkip test_integration.py to avoid bugs 486736 and 489870. (diff)
downloadhistorical-5edf68953258a1b04307b549546b27c1e5df2075.tar.gz
historical-5edf68953258a1b04307b549546b27c1e5df2075.tar.bz2
historical-5edf68953258a1b04307b549546b27c1e5df2075.zip
Version bump.
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-libs/libexplain/libexplain-1.3.ebuild')
-rw-r--r--dev-libs/libexplain/libexplain-1.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libexplain/libexplain-1.3.ebuild b/dev-libs/libexplain/libexplain-1.3.ebuild
new file mode 100644
index 000000000000..73cb336a8766
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.3.ebuild,v 1.1 2013/11/30 04:12:51 radhermit Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="doc static-libs"
+
+RDEPEND="
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11
+ sys-process/lsof"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.35
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+"
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}" || die
+
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile all-doc
+}