summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-02-19 15:11:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-02-19 15:11:03 +0000
commit345188a5fea8d4a345e46266c8058c74ddf7b63f (patch)
tree0ba69f4c4f35b9c9c06be0d074025ea166905dc1 /dev-libs/libots
parentmarked ~alpha (diff)
downloadhistorical-345188a5fea8d4a345e46266c8058c74ddf7b63f.tar.gz
historical-345188a5fea8d4a345e46266c8058c74ddf7b63f.tar.bz2
historical-345188a5fea8d4a345e46266c8058c74ddf7b63f.zip
use rpm.eclass instead of rpm2targz, and doins/dolib/etc instead of cp
Diffstat (limited to 'dev-libs/libots')
-rw-r--r--dev-libs/libots/ChangeLog5
-rw-r--r--dev-libs/libots/Manifest8
-rw-r--r--dev-libs/libots/files/digest-libots-2.2.7-r21
-rw-r--r--dev-libs/libots/libots-2.2.7-r2.ebuild31
4 files changed, 41 insertions, 4 deletions
diff --git a/dev-libs/libots/ChangeLog b/dev-libs/libots/ChangeLog
index 69f7ccbe8603..45c784d3bcd8 100644
--- a/dev-libs/libots/ChangeLog
+++ b/dev-libs/libots/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libots
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/ChangeLog,v 1.6 2004/02/07 00:53:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/ChangeLog,v 1.7 2004/02/19 15:11:03 taviso Exp $
+
+ 19 Feb 2004; Tavis Ormandy <taviso@gentoo.org> :
+ use the new rpm.eclass, change the syntax do use into, dolib, etc.
*libots-2.2.7-r1 (06 Feb 2004)
diff --git a/dev-libs/libots/Manifest b/dev-libs/libots/Manifest
index 5f58333b6f15..e2cb22efcbbd 100644
--- a/dev-libs/libots/Manifest
+++ b/dev-libs/libots/Manifest
@@ -1,6 +1,8 @@
-MD5 6e9e440cb4edfa86f1c5319926be2feb ChangeLog 654
+MD5 a81b88f2d6baaf9849bfb0abf1c32a12 libots-2.2.7-r2.ebuild 727
MD5 d5b3fd4782d48a53f195dcf847095f5f libots-2.2.7-r1.ebuild 797
-MD5 d0ec81a70aa1af5bc20cc9bc02f0aca4 metadata.xml 382
MD5 8c75bbf53f15707693d8ba6f0997a264 libots-2.2.7.ebuild 874
-MD5 24217a4a8cbf67a8f09647b179a10571 files/digest-libots-2.2.7 68
+MD5 eb92e98d494587a0f410321d904c709e ChangeLog 773
+MD5 d0ec81a70aa1af5bc20cc9bc02f0aca4 metadata.xml 382
MD5 24217a4a8cbf67a8f09647b179a10571 files/digest-libots-2.2.7-r1 68
+MD5 24217a4a8cbf67a8f09647b179a10571 files/digest-libots-2.2.7-r2 68
+MD5 24217a4a8cbf67a8f09647b179a10571 files/digest-libots-2.2.7 68
diff --git a/dev-libs/libots/files/digest-libots-2.2.7-r2 b/dev-libs/libots/files/digest-libots-2.2.7-r2
new file mode 100644
index 000000000000..11837f4bb110
--- /dev/null
+++ b/dev-libs/libots/files/digest-libots-2.2.7-r2
@@ -0,0 +1 @@
+MD5 4b6337865c798f821850e20502964ae0 libots-2.2.7-2.alpha.rpm 94336
diff --git a/dev-libs/libots/libots-2.2.7-r2.ebuild b/dev-libs/libots/libots-2.2.7-r2.ebuild
new file mode 100644
index 000000000000..4e86416e8b39
--- /dev/null
+++ b/dev-libs/libots/libots-2.2.7-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libots/libots-2.2.7-r2.ebuild,v 1.1 2004/02/19 15:11:03 taviso Exp $
+
+inherit eutils rpm
+
+At="libots-2.2.7-2.alpha.rpm"
+HOMEPAGE="http://www.support.compaq.com/alpha-tools/"
+DESCRIPTION="Compaq Linux optimized runtime for Alpha/Linux/GNU"
+SRC_URI="ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/${At}"
+
+DEPEND="virtual/glibc"
+LICENSE="compaq-sdla"
+SLOT="2.2.7"
+KEYWORDS="-* ~alpha"
+
+S=${WORKDIR}/usr/lib/compaq/libots-2.2.7
+
+RESTRICT="nostrip"
+
+src_unpack() {
+ rpm_src_unpack
+}
+
+src_install () {
+ into /
+ dolib.so libots.so
+ dolib.a libots.a
+
+ dodoc README
+}