summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-11-20 01:02:23 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-11-20 01:02:23 +0000
commit26481980b8c9b0b70a71365bd4efcb4faeebb0a6 (patch)
treefe1ee1e0e3709254e7d0bb9700c739249e48ef41 /dev-libs/log4c/files/log4c-1.0.10-nodocs.patch
parentppc stable (diff)
downloadhistorical-26481980b8c9b0b70a71365bd4efcb4faeebb0a6.tar.gz
historical-26481980b8c9b0b70a71365bd4efcb4faeebb0a6.tar.bz2
historical-26481980b8c9b0b70a71365bd4efcb4faeebb0a6.zip
log4c-1.0.10-r1 added per bug #70529.
Diffstat (limited to 'dev-libs/log4c/files/log4c-1.0.10-nodocs.patch')
-rw-r--r--dev-libs/log4c/files/log4c-1.0.10-nodocs.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/log4c/files/log4c-1.0.10-nodocs.patch b/dev-libs/log4c/files/log4c-1.0.10-nodocs.patch
new file mode 100644
index 000000000000..0759afbf99b5
--- /dev/null
+++ b/dev-libs/log4c/files/log4c-1.0.10-nodocs.patch
@@ -0,0 +1,38 @@
+diff -Nru log4c-1.0.10.orig/configure log4c-1.0.10/configure
+--- log4c-1.0.10.orig/configure 2002-11-22 08:44:32.000000000 -0600
++++ log4c-1.0.10/configure 2004-11-16 10:32:32.303881856 -0600
+@@ -9522,6 +9522,7 @@
+ else
+ enable_doc=yes
+ fi
++enable_doc=no
+
+
+ if test x$enable_doc = xyes; then
+@@ -9532,7 +9533,7 @@
+ DOC_FALSE=
+ fi
+
+-ac_config_files="$ac_config_files Makefile log4c-config log4crc.sample log4c.spec config/Makefile doc/Makefile doc/Doxyfile doc/main.doc src/Makefile src/log4c/Makefile src/log4c/version.h src/sd/Makefile tests/Makefile tests/log4c/Makefile"
++ac_config_files="$ac_config_files Makefile log4c-config log4crc.sample log4c.spec config/Makefile src/Makefile src/log4c/Makefile src/log4c/version.h src/sd/Makefile tests/Makefile tests/log4c/Makefile"
+
+ ac_config_commands="$ac_config_commands default"
+
+diff -Nru log4c-1.0.10.orig/tests/log4c/test_category.c log4c-1.0.10/tests/log4c/test_category.c
+--- log4c-1.0.10.orig/tests/log4c/test_category.c 2002-11-20 09:38:34.000000000 -0600
++++ log4c-1.0.10/tests/log4c/test_category.c 2004-11-16 11:53:53.436836856 -0600
+@@ -111,11 +111,11 @@
+ {
+ log4c_category_set_priority(root, LOG4C_PRIORITY_TRACE);
+
+- foo(root, trace);
++ foo(root, info);
+ foo(root, warn);
+- foo(sub1, trace);
++ foo(sub1, info);
+ foo(sub1, warn);
+- foo(sun1sub2, trace);
++ foo(sun1sub2, info);
+ foo(sun1sub2, warn);
+ return 1;
+ }