summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-11-08 08:52:32 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-11-08 08:52:32 +0000
commit99ef2c30425abf77b0992b32827e854807febcb0 (patch)
tree5b39155dab613b93a17c271ab75971e66895fcb7 /dev-libs/ntl/ntl-5.3.ebuild
parentSmall fix, closes #10406. (diff)
downloadhistorical-99ef2c30425abf77b0992b32827e854807febcb0.tar.gz
historical-99ef2c30425abf77b0992b32827e854807febcb0.tar.bz2
historical-99ef2c30425abf77b0992b32827e854807febcb0.zip
new package -ntl - library for efficient computation
Diffstat (limited to 'dev-libs/ntl/ntl-5.3.ebuild')
-rw-r--r--dev-libs/ntl/ntl-5.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/ntl/ntl-5.3.ebuild b/dev-libs/ntl/ntl-5.3.ebuild
new file mode 100644
index 000000000000..df441ba75d69
--- /dev/null
+++ b/dev-libs/ntl/ntl-5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-5.3.ebuild,v 1.1 2002/11/08 08:52:32 george Exp $
+
+IUSE=""
+
+DESCRIPTION="high-performance, portable C++ ci-computational ibrar"
+HOMEPAGE="http://shoup.net/ntl/"
+SRC_URI="http://www.shoup.net/ntl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND=">=gmp-4.1-r1"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ cd src
+ ./configure \
+ PREFIX=/usr \
+ NTL_GMP_LIP=on \
+ "CFLAGS=$CFLAGS -Wno-deprecated" || die "./configure failed"
+
+ make || die "make failed"
+ make check || die "make check failed - make did not make something good..."
+}
+
+src_install() {
+ cd src
+ make PREFIX=${D}/usr/ install || die
+
+ #now somewhat clean-up docs
+ cd ${S}
+ dodoc README
+ cd ${S}/doc
+ dodoc *.txt
+ dohtml *.html *.gif
+
+ rm -rf ${D}/usr/doc
+}