summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-15 21:43:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-15 21:43:15 +0000
commit19df29ea8e37efb2958ca557a6780fc0f36d37c9 (patch)
tree264a345130c9fdcce60fdc0e7658066a88929a09 /dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
parentFix quoting (diff)
downloadhistorical-19df29ea8e37efb2958ca557a6780fc0f36d37c9.tar.gz
historical-19df29ea8e37efb2958ca557a6780fc0f36d37c9.tar.bz2
historical-19df29ea8e37efb2958ca557a6780fc0f36d37c9.zip
Raise glib and gtk-doc-am dependencies. Add missing preserve_old_lib calls. Remove deprecated src_prepare code. Explicit dependency on gmime 2.4 slot. Add introspection USE flag to avoid automagic activation.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild')
-rw-r--r--dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild42
1 files changed, 17 insertions, 25 deletions
diff --git a/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
index 0af0b854740c..6dd96558ab3f 100644
--- a/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
+++ b/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild,v 1.4 2010/08/01 11:14:39 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/totem-pl-parser/totem-pl-parser-2.30.1.ebuild,v 1.5 2010/08/15 21:43:15 eva Exp $
EAPI="2"
-
GCONF_DEBUG="no"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Playlist parsing library"
HOMEPAGE="http://www.gnome.org/projects/totem/"
@@ -15,15 +14,14 @@ LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
# TODO: Re-generate doc ?
-# TODO: Introspection
-IUSE="doc test"
+IUSE="doc introspection test"
-RDEPEND=">=dev-libs/glib-2.21.6
- >=dev-libs/gmime-2.4"
+RDEPEND=">=dev-libs/glib-2.24
+ dev-libs/gmime:2.4"
DEPEND="${RDEPEND}
!<media-video/totem-2.21
>=dev-util/intltool-0.35
- dev-util/gtk-doc-am
+ >=dev-util/gtk-doc-am-1.11
doc? ( >=dev-util/gtk-doc-1.11 )"
DOCS="AUTHORS ChangeLog NEWS"
@@ -32,21 +30,15 @@ pkg_setup() {
G2CONF="${G2CONF} --disable-static $(use_enable introspection)"
}
-src_prepare() {
- gnome2_src_prepare
-
- # FIXME: disable some broken tests, report upstream
- sed -e 's,^\(.*/parser/resolution.*\)$,/*\1*/,' \
- -e 's,^\(.*/parser/parsability.*\)$,/*\1*/,' \
- -e 's,^\(.*/parser/parsing/hadess.*\)$,/*\1*/,' \
- -i plparse/tests/parser.c || die
-
- # FIXME: tarball generated with broken gtk-doc, revisit me.
- if use doc; then
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" \
- -i gtk-doc.make || die "sed 1 failed"
- else
- sed "/^TARGET_DIR/i \GTKDOC_REBASE=$(type -P true)" \
- -i gtk-doc.make || die "sed 2 failed"
- fi
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ emake check || die "emake check failed"
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libtotem-plparser-mini.so.12
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libtotem-plparser-mini.so.12
}