summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-31 08:58:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-31 08:58:47 +0000
commit420438257688872b0725bac2569e3d7001f2eff8 (patch)
tree74c2bf736486f6e5c344e94da09db6f1ab6bf99e /dev-libs/yaz/yaz-3.0.47.ebuild
parentInvalid headers. Invalid entries. (diff)
downloadhistorical-420438257688872b0725bac2569e3d7001f2eff8.tar.gz
historical-420438257688872b0725bac2569e3d7001f2eff8.tar.bz2
historical-420438257688872b0725bac2569e3d7001f2eff8.zip
Bug #277853: version bump. Thanks to John Klehm <xixsimplicityxix@gmail.com>.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/yaz/yaz-3.0.47.ebuild')
-rw-r--r--dev-libs/yaz/yaz-3.0.47.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/yaz/yaz-3.0.47.ebuild b/dev-libs/yaz/yaz-3.0.47.ebuild
new file mode 100644
index 000000000000..f7f818e330e1
--- /dev/null
+++ b/dev-libs/yaz/yaz-3.0.47.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yaz/yaz-3.0.47.ebuild,v 1.1 2009/07/31 08:58:47 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="C/C++ programmer's toolkit supporting the development of Z39.50v3 clients and servers"
+HOMEPAGE="http://www.indexdata.dk/yaz"
+SRC_URI="http://ftp.indexdata.dk/pub/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug icu tcpd ziffy"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/openssl
+ icu? ( dev-libs/icu )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ziffy? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/tcl
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.47-icu-automagic.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_enable debug memdebug) \
+ $(use_enable icu) \
+ $(use_enable tcpd tcpd /usr)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ local docdir="/usr/share/doc/${PF}"
+ emake DESTDIR="${D}" docdir="${docdir}" install || die "install failed"
+
+ dodir ${docdir}/html
+ mv -f "${D}"/${docdir}/*.{html,png} "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ mv -f "${D}"/usr/share/doc/${PN}/common "${D}"/${docdir}/html/ || die "Failed to move HTML docs"
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc ChangeLog NEWS README
+}