summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-06-07 05:45:26 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-06-07 05:45:26 +0000
commitc2e5df8edf3beab3d12637b7124dce0329c6e5b4 (patch)
tree7ec3d8579dfaf2444568cb1a795d15416b28180c /dev-libs
parentQA - IUSE fix (diff)
downloadhistorical-c2e5df8edf3beab3d12637b7124dce0329c6e5b4.tar.gz
historical-c2e5df8edf3beab3d12637b7124dce0329c6e5b4.tar.bz2
historical-c2e5df8edf3beab3d12637b7124dce0329c6e5b4.zip
Adding ~amd64 keywords
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/root/ChangeLog5
-rw-r--r--dev-libs/root/Manifest12
-rw-r--r--dev-libs/root/root-3.10.02.ebuild16
3 files changed, 22 insertions, 11 deletions
diff --git a/dev-libs/root/ChangeLog b/dev-libs/root/ChangeLog
index fd4fc401ef0d..7bf7375f119c 100644
--- a/dev-libs/root/ChangeLog
+++ b/dev-libs/root/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/root
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/ChangeLog,v 1.12 2004/04/20 13:43:11 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/ChangeLog,v 1.13 2004/06/07 05:45:26 phosphan Exp $
+
+ 07 Jun 2004; Patrick Kursawe <phosphan@gentoo.org> root-3.10.02.ebuild:
+ According to user report (forums/slackerman) it works for amd64.
*root-3.10.02 (20 Apr 2004)
diff --git a/dev-libs/root/Manifest b/dev-libs/root/Manifest
index 88147bcf89b5..5737a385312a 100644
--- a/dev-libs/root/Manifest
+++ b/dev-libs/root/Manifest
@@ -1,9 +1,9 @@
-MD5 fe1aa79a3f5b543e4a5e73dfcbe5f148 ChangeLog 1630
-MD5 0019b8e643dd87a2f31dbbca938406aa root-3.03.04-r2.ebuild 1627
MD5 2bb351ad29c16f1796c15629559fd2d6 root-3.05.04.ebuild 1623
-MD5 936e08d06758faeb3a840939d52ea1c7 root-3.10.02.ebuild 4556
-MD5 cb6730d3f0de83973de47c6bf1d82cfa files/digest-root-3.03.04-r2 73
-MD5 053f8a5dbe37435f2b62ee44c79e9523 files/digest-root-3.05.04 73
-MD5 1ef2792a1fad865173670aa5942bef6c files/pgsql-no-libpq-int.patch 290
+MD5 0019b8e643dd87a2f31dbbca938406aa root-3.03.04-r2.ebuild 1627
+MD5 7f5c4189d1e3f6fb8589546e7b3014d2 root-3.10.02.ebuild 4675
+MD5 0e2e33f20c7588e4c0cbcedfc2a86d8c ChangeLog 1771
MD5 58ce6f63773b28de747663b7e908e2bb files/root-makefile.patch 742
+MD5 053f8a5dbe37435f2b62ee44c79e9523 files/digest-root-3.05.04 73
MD5 da92522ba08f8d50e5197b6a9fd7549f files/digest-root-3.10.02 74
+MD5 cb6730d3f0de83973de47c6bf1d82cfa files/digest-root-3.03.04-r2 73
+MD5 1ef2792a1fad865173670aa5942bef6c files/pgsql-no-libpq-int.patch 290
diff --git a/dev-libs/root/root-3.10.02.ebuild b/dev-libs/root/root-3.10.02.ebuild
index abc671e449eb..8d30c99dbbc0 100644
--- a/dev-libs/root/root-3.10.02.ebuild
+++ b/dev-libs/root/root-3.10.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.10.02.ebuild,v 1.2 2004/04/21 21:15:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/root/root-3.10.02.ebuild,v 1.3 2004/06/07 05:45:26 phosphan Exp $
inherit flag-o-matic eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://root.cern.ch/"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="mysql postgres opengl afs kerberos ldap qt"
DEPEND="virtual/x11
@@ -20,12 +20,15 @@ DEPEND="virtual/x11
opengl? ( virtual/opengl virtual/glu )
mysql? ( >=dev-db/mysql-3.23.49 )
postgres? ( >=dev-db/postgresql-7.1.3-r4 )
- afs? ( net-fs/openafs )
+ !amd64? ( afs? ( net-fs/openafs ) )
kerberos? ( app-crypt/mit-krb5 )
ldap? ( net-nds/openldap )
qt? ( x11-libs/qt )"
src_compile() {
+
+ local myconf
+
if [ "x$CERNLIB" = "x" ]
then
einfo "No support for cernlib, (h/g)2root will not be build."
@@ -107,6 +110,12 @@ src_compile() {
append-flags "-fsigned-char";;
esac
+ if ! use amd64; then
+ myconf="${myconf} $(use_enable afs)"
+ else
+ myconf="${myconf} --disable-afs"
+ fi
+
./configure linux \
--aclocaldir=/usr/share/aclocal/ \
--bindir=/usr/bin \
@@ -126,7 +135,6 @@ src_compile() {
--srcdir=/usr/share/root/src \
--testdir=/usr/share/doc/${P}/test \
--tutdir=/usr/share/doc/${P}/tutorial \
- `use_enable afs` \
--disable-alien \
--disable-asimage \
$USECERN \