summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-03 17:57:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-03 17:57:51 +0000
commita317b23519f1e5d92e248c85f18832af2633d316 (patch)
tree5dc6435676e4376f08beb0ab0706d18612c1febf /dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild
parentStable on hppa. (diff)
downloadhistorical-a317b23519f1e5d92e248c85f18832af2633d316.tar.gz
historical-a317b23519f1e5d92e248c85f18832af2633d316.tar.bz2
historical-a317b23519f1e5d92e248c85f18832af2633d316.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild')
-rw-r--r--dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild b/dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild
new file mode 100644
index 000000000000..14e8e78dd6aa
--- /dev/null
+++ b/dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-closer-mop/cl-closer-mop-0.31.ebuild,v 1.1 2006/02/03 17:57:51 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Closer to MOP is a compatibility layer that rectifies many of the absent or incorrect MOP features as detected by MOP Feature Tests."
+HOMEPAGE="http://common-lisp.net/project/closer/closer-mop.html"
+SRC_URI="ftp://common-lisp.net/pub/project/closer/${P/cl-/}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-lw-compat"
+
+CLPACKAGE=closer-mop
+
+S=${WORKDIR}/closer-mop
+
+src_install() {
+ common-lisp-install *.{asd,lisp}
+ common-lisp-system-symlink
+ for i in allegro clisp lispworks mcl pcl test; do
+ insinto $CLSOURCEROOT/$CLPACKAGE/$i
+ doins $i/*.lisp
+ done
+ dodoc *.txt
+}