summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-04-24 20:41:58 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-04-24 20:41:58 +0000
commit02e08cd6c24afc998182565cadbe099d1c32c2e7 (patch)
treec9e9be710212588727f978ee28b7718a71543f52 /dev-lisp/clisp/files
parentStable on sparc (diff)
downloadhistorical-02e08cd6c24afc998182565cadbe099d1c32c2e7.tar.gz
historical-02e08cd6c24afc998182565cadbe099d1c32c2e7.tar.bz2
historical-02e08cd6c24afc998182565cadbe099d1c32c2e7.zip
Adjust the fastcgi module so that .. does not appear without a -I in the call to GCC; Possibly resolves Bug #119463.
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'dev-lisp/clisp/files')
-rw-r--r--dev-lisp/clisp/files/2.38/fastcgi-Makefile-gentoo.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-lisp/clisp/files/2.38/fastcgi-Makefile-gentoo.patch b/dev-lisp/clisp/files/2.38/fastcgi-Makefile-gentoo.patch
new file mode 100644
index 000000000000..ffe24d237751
--- /dev/null
+++ b/dev-lisp/clisp/files/2.38/fastcgi-Makefile-gentoo.patch
@@ -0,0 +1,16 @@
+diff -ur clisp-2.38.orig/modules/fastcgi/Makefile.in clisp-2.38/modules/fastcgi/Makefile.in
+--- clisp-2.38.orig/modules/fastcgi/Makefile.in 2004-08-12 09:38:36.000000000 -0500
++++ clisp-2.38/modules/fastcgi/Makefile.in 2006-04-24 15:14:38.000000000 -0500
+@@ -23,10 +23,10 @@
+ $(CLISP) -c fastcgi.lisp
+
+ fastcgi.o: fastcgi.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I$(INCLUDES) -I.. -c fastcgi.c
+
+ fastcgi_wrappers.o: fastcgi_wrappers.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) $(INCLUDES) -I.. -c fastcgi_wrappers.c
++ $(CC) $(CPPFLAGS) $(CFLAGS) -I$(INCLUDES) -I.. -c fastcgi_wrappers.c
+
+ # Make a module
+ clisp-module : all