summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
commitf64df7559351f5ed153c74f4b53274e97659bb69 (patch)
tree93e4faf76267607b95f9f5cd7d3f9f11fcf86696 /dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
parentShorten DESCRIPTION to under 100 characters in order to make repoman happy. (diff)
downloadhistorical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.gz
historical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.bz2
historical-f64df7559351f5ed153c74f4b53274e97659bb69.zip
Migrate to EAPI 2 in order to nuke built_with_use.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild')
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild24
1 files changed, 7 insertions, 17 deletions
diff --git a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
index ed7269011c97..d14debb42c3b 100644
--- a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
+++ b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.4 2008/07/13 06:56:01 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.5 2009/09/28 16:53:50 betelgeuse Exp $
-EAPI="1"
+EAPI="2"
inherit findlib eutils
@@ -12,7 +12,8 @@ DESCRIPTION="OCaml bindings for expat"
SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
-RDEPEND="dev-libs/expat"
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2[ocamlopt?]"
DEPEND="${RDEPEND}
test? ( dev-ml/ounit )"
@@ -21,18 +22,7 @@ SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~ppc ~x86"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
+src_prepare(){
epatch "${FILESDIR}/${P}-test.patch"
}
@@ -57,5 +47,5 @@ src_install() {
if use doc ; then
dohtml -r doc/html/*
fi
- dodoc README
+ dodoc README || die
}