summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-03-15 20:04:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-03-15 20:04:27 +0000
commitb8c038ab07e56ddd9386d63b4698aea6f042ffd6 (patch)
tree797f3a7c8834fdd4d75340e2f9b46218d4ff6677 /dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild
parentVersion bump to fix bug #358943. Thanks to Oliver Nautsch <oliver.nautsch@gma... (diff)
downloadhistorical-b8c038ab07e56ddd9386d63b4698aea6f042ffd6.tar.gz
historical-b8c038ab07e56ddd9386d63b4698aea6f042ffd6.tar.bz2
historical-b8c038ab07e56ddd9386d63b4698aea6f042ffd6.zip
Initial import, ebuild by Vladimir Ivanov, bug #355755, with modifications and simplifications by me
Package-Manager: portage-2.2.0_alpha27/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild')
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild
new file mode 100644
index 000000000000..2a44549a5ecf
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild,v 1.1 2011/03/15 20:04:27 aballier Exp $
+
+EAPI=3
+
+inherit findlib
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-fileutils"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/462/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-ml/findlib"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_prepare() {
+ use ocamlopt || sed -i -e 's/OCAMLBEST=.*/OCAMLBEST=byte/' configure
+}
+
+src_install() {
+ findlib_src_preinst
+ emake htmldir="${ED}/usr/share/doc/${PF}/html" install || die
+ dodoc README CHANGELOG || die "doc isntall failed"
+}