summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-19 18:39:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-19 18:39:29 +0000
commitb383cd4219a8a7f8704a34158cf4f48cdb4f3267 (patch)
treecaa0b6c0eeed8d0ec47250b9d56d6c5a2169bdf2 /dev-ml/ocaml-ssl
parentversion bump (diff)
downloadhistorical-b383cd4219a8a7f8704a34158cf4f48cdb4f3267.tar.gz
historical-b383cd4219a8a7f8704a34158cf4f48cdb4f3267.tar.bz2
historical-b383cd4219a8a7f8704a34158cf4f48cdb4f3267.zip
version bump
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-ssl')
-rw-r--r--dev-ml/ocaml-ssl/ChangeLog9
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.5.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-ml/ocaml-ssl/ChangeLog b/dev-ml/ocaml-ssl/ChangeLog
index e9d35c2305a9..18cee894b43b 100644
--- a/dev-ml/ocaml-ssl/ChangeLog
+++ b/dev-ml/ocaml-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-ssl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.17 2010/07/17 09:30:21 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.18 2011/04/19 18:37:01 aballier Exp $
+
+*ocaml-ssl-0.4.5 (19 Apr 2011)
+
+ 19 Apr 2011; Alexis Ballier <aballier@gentoo.org> +ocaml-ssl-0.4.5.ebuild:
+ version bump
*ocaml-ssl-0.4.4 (17 Jul 2010)
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.5.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.5.ebuild
new file mode 100644
index 000000000000..9a6347cf9a6a
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ocaml-ssl-0.4.5.ebuild,v 1.1 2011/04/19 18:37:01 aballier Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL."
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}