summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-08-08 10:09:16 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-08-08 10:09:16 +0000
commitc77f63562a3b57bcc33b0a7429c8221bbf7866c9 (patch)
tree5cd2a85fd977a5a49db9671bcb345a6542a3009a /dev-perl/HTML-Mason
parentmodperl use flag (diff)
downloadhistorical-c77f63562a3b57bcc33b0a7429c8221bbf7866c9.tar.gz
historical-c77f63562a3b57bcc33b0a7429c8221bbf7866c9.tar.bz2
historical-c77f63562a3b57bcc33b0a7429c8221bbf7866c9.zip
New version of mason, works with modperl2, rendhalver - thanks :)
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.29_beta02.ebuild100
-rw-r--r--dev-perl/HTML-Mason/Manifest10
-rw-r--r--dev-perl/HTML-Mason/files/digest-HTML-Mason-1.29_beta021
4 files changed, 114 insertions, 5 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index f8ba8f64be0c..f5d4989cd890 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.33 2005/05/25 13:42:21 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.34 2005/08/08 10:09:16 mcummings Exp $
+
+*HTML-Mason-1.29_beta02 (08 Aug 2005)
+
+ 08 Aug 2005; Michael Cummings <mcummings@gentoo.org>
+ +HTML-Mason-1.29_beta02.ebuild:
+ New version of mason, works with modperl2, rendhalver - thanks :)
25 May 2005; Michael Cummings <mcummings@gentoo.org> HTML-Mason-1.28.ebuild:
dev-perl/File-Spec => perl-core/File-Spec migration
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.29_beta02.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.29_beta02.ebuild
new file mode 100644
index 000000000000..fd5200798ae3
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.29_beta02.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.29_beta02.ebuild,v 1.1 2005/08/08 10:09:16 mcummings Exp $
+
+inherit perl-module
+
+MY_P=${P/beta/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${MY_P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha"
+IUSE="apache2 modperl"
+SRC_TEST="do"
+
+DEPEND="${DEPEND}
+ || ( perl-core/CGI
+ modperl?
+ (
+ !apache2? ( =net-www/apache-1* >=www-apache/libapreq-1.0-r2 )
+ apache2? ( >=net-www/apache-2 www-apache/libapreq2 )
+ )
+ )
+ >=dev-perl/Params-Validate-0.24-r2
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.14
+ dev-perl/Scalar-List-Utils
+ || ( perl-core/File-Spec >=dev-lang/perl-5.8.0-r12 )
+ >=dev-perl/Cache-Cache-1.01"
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ if use apache2; then
+ APACHE="/usr/sbin/apache2"
+ else
+ APACHE="/usr/sbin/apache"
+ fi
+
+ perlinfo
+
+ export PERL_MM_USE_DEFAULT=1
+
+
+ SRC_PREP="yes"
+ einfo "Using Module::Build"
+ if [ -z ${BUILDER_VER} ]; then
+ eerror
+ eerror "Please post a bug on http://bugs.gentoo.org assigned to"
+ eerror "perl@gentoo.org - ${P} was added without a dependancy"
+ eerror "on dev-perl/module-build"
+ eerror "${BUILDER_VER}"
+ eerror
+ die
+ else
+ APACHE="${APACHE}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+ fi
+}
+
+src_install () {
+ # rendhalver - these bits arent needed for this version
+ #This is a nasty fix for a sandbox violation that Mason wants to do
+ #mv -f install/delete_old_pods.pl install/delete_old_pods.pl2
+ #sed -e "s/use strict/exit()/" install/delete_old_pods.pl2 > install/delete_old_pods.pl
+
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ dohtml -r htdocs/*
+}
+
+
+pkg_postinst() {
+ # rendhalver - and we can probably turn this off now
+ # but i am not sure which version of Mason did this.
+
+ einfo
+ einfo "Due to a change in documention in HTML-Mason, you will need to note"
+ einfo "that the documentation in the following files is no longer valid."
+ einfo "These files are present only if you had a previous install of "
+ einfo "HTML-Mason. Feel free to remove these docs from your system: "
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Interp.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/ApacheHandler.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Request.pod"
+ einfo "/usr/lib/perl5/site_perl/PERLVERSION/HTML/Mason/Component.pod"
+ einfo "Where PERLVERSION is your version of perl (5.6.1, 5.8)"
+ einfo
+
+}
diff --git a/dev-perl/HTML-Mason/Manifest b/dev-perl/HTML-Mason/Manifest
index 90ea901e451a..9ae823daf632 100644
--- a/dev-perl/HTML-Mason/Manifest
+++ b/dev-perl/HTML-Mason/Manifest
@@ -1,22 +1,24 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 b3b89d82e79972983aceb4138f69f5dc ChangeLog 5389
+MD5 443df9f35f85c5707555f7b34820786c ChangeLog 5586
MD5 ae0e9d609b2eb36d3aa72cdcd85911e6 HTML-Mason-1.20.ebuild 1748
MD5 5b6e32080ab622b665b04c814491c0e5 HTML-Mason-1.22.ebuild 1749
MD5 7dc238ab55536fc6f5f6d3d3108749d0 HTML-Mason-1.25.ebuild 1749
MD5 b54ff85c24be1f71a8faa3c5b408d6a3 HTML-Mason-1.26.ebuild 1749
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
MD5 69c8b8d622913bcf7de8134b229f68bb HTML-Mason-1.28.ebuild 2015
+MD5 8b47887d1fe1374e18ea9bb06e791fa3 HTML-Mason-1.29_beta02.ebuild 3028
MD5 ab2c0618efa7e72fc2bf1f5c32002058 files/digest-HTML-Mason-1.20 67
MD5 1fc7a530b801966564b7dc476e5146da files/digest-HTML-Mason-1.22 67
MD5 07de1ec3aa725a31db3b84f7a98cabda files/digest-HTML-Mason-1.25 67
MD5 3ab48da347fd0409815b3952c646baa6 files/digest-HTML-Mason-1.26 67
MD5 3666de3807611da57648d2ee49ddeca2 files/digest-HTML-Mason-1.28 67
+MD5 a2bb428fba57ac3e4e9c8789b7fc58ac files/digest-HTML-Mason-1.29_beta02 70
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFClIDRtG5z4I8BtQoRAkJGAJwNi2bimfrDKXzvLo9EQotZY5eAogCfbr+O
-zqe8GGRoZPokViTSNrX0TGs=
-=Y9jl
+iD8DBQFC9y9etG5z4I8BtQoRAt28AJ9zULdKFOTXaOnG1qwEx3ZFSx7xwQCcDlV1
+p4r9xKLm5AJFjynx8Iu4090=
+=JlNl
-----END PGP SIGNATURE-----
diff --git a/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.29_beta02 b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.29_beta02
new file mode 100644
index 000000000000..350f74524ce7
--- /dev/null
+++ b/dev-perl/HTML-Mason/files/digest-HTML-Mason-1.29_beta02
@@ -0,0 +1 @@
+MD5 fa59785165d14b40b710e47b462f4aad HTML-Mason-1.29_02.tar.gz 376575