summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-03-30 20:09:17 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-03-30 20:09:17 +0000
commit934bb8d62e4f53487b9fc69d24d4dc133d4278d0 (patch)
tree8ff0f0a6c1901755728d98691bebe4b72ab51609 /dev-perl/Inline-Java/Inline-Java-0.50.ebuild
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadhistorical-934bb8d62e4f53487b9fc69d24d4dc133d4278d0.tar.gz
historical-934bb8d62e4f53487b9fc69d24d4dc133d4278d0.tar.bz2
historical-934bb8d62e4f53487b9fc69d24d4dc133d4278d0.zip
bug 169288
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'dev-perl/Inline-Java/Inline-Java-0.50.ebuild')
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.50.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
index a7468f9c4c65..38b4f41adae3 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.7 2007/01/21 19:15:20 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.8 2007/03/30 20:09:17 mcummings Exp $
inherit perl-module
@@ -18,9 +18,19 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
- >=virtual/jdk-1.4
+ >=virtual/jdk-1.4
+ dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
+pkg_setup() {
+ if [ $(java-config -O | grep jdk ) ]; then
+ true
+ else
+ eerror "Please use java-config -S to set your system vm to a JDK"
+ die "Active VM is not a JDK"
+ fi
+}
+