summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-05-30 14:46:31 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-05-30 14:46:31 +0000
commit198e440f4b8ed03009a69b6964ea8b1d689be364 (patch)
tree5a29efcc3b6d0efdf54a994510fe1f21636b908b /dev-perl/libwww-perl/libwww-perl-5.803.ebuild
parentcorrected libical path (diff)
downloadhistorical-198e440f4b8ed03009a69b6964ea8b1d689be364.tar.gz
historical-198e440f4b8ed03009a69b6964ea8b1d689be364.tar.bz2
historical-198e440f4b8ed03009a69b6964ea8b1d689be364.zip
Version bump, version dep for new RPC-XML
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-5.803.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.803.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-5.803.ebuild b/dev-perl/libwww-perl/libwww-perl-5.803.ebuild
new file mode 100644
index 000000000000..59f851a9cee9
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.803.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.803.ebuild,v 1.1 2005/05/30 14:46:31 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+SRC_URI="mirror://cpan/authors/id/G/GA/GAAS/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~gaas/${P}/"
+IUSE="ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-perl/libnet-1.16
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=perl-core/Digest-MD5-2.12
+ >=perl-core/MIME-Base64-2.12
+ dev-perl/Compress-Zlib
+ ssl? ( dev-perl/Crypt-SSLeay )"
+
+src_compile() {
+ yes "" | perl Makefile.PL ${myconf} \
+ PREFIX=${D}/usr INSTALLDIRS=vendor
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+}