summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-04-11 16:27:39 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-04-11 16:27:39 +0000
commit45166443fb400d0e26e12c2142f4707e86b5040c (patch)
treee75ddee0bc978527f68b017a79889721475f7638 /dev-perl/math-pari/math-pari-2.010603.ebuild
parentsyntax fixes (diff)
downloadhistorical-45166443fb400d0e26e12c2142f4707e86b5040c.tar.gz
historical-45166443fb400d0e26e12c2142f4707e86b5040c.tar.bz2
historical-45166443fb400d0e26e12c2142f4707e86b5040c.zip
bump
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-perl/math-pari/math-pari-2.010603.ebuild')
-rw-r--r--dev-perl/math-pari/math-pari-2.010603.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/math-pari/math-pari-2.010603.ebuild b/dev-perl/math-pari/math-pari-2.010603.ebuild
new file mode 100644
index 000000000000..a7d8fcb1598a
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010603.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010603.ebuild,v 1.1 2005/04/11 16:25:48 mcummings Exp $
+
+inherit perl-module
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.6.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~mips"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+DEPEND="~sci-mathematics/pari-2.1.6"