summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-10-31 00:58:40 +0000
committerRobert Coie <rac@gentoo.org>2003-10-31 00:58:40 +0000
commit01cd6ee432610c0c19f637059b0260965114e2bd (patch)
tree22edeca85df5292a7ae810323c4005ea066de6ef /dev-perl/mod_perl
parentadd 1.99.10 (diff)
downloadhistorical-01cd6ee432610c0c19f637059b0260965114e2bd.tar.gz
historical-01cd6ee432610c0c19f637059b0260965114e2bd.tar.bz2
historical-01cd6ee432610c0c19f637059b0260965114e2bd.zip
add 1.99.10
Diffstat (limited to 'dev-perl/mod_perl')
-rw-r--r--dev-perl/mod_perl/Manifest3
-rw-r--r--dev-perl/mod_perl/files/digest-mod_perl-1.99.101
-rw-r--r--dev-perl/mod_perl/files/mod_perl-1.99.10-nonukes.patch24
-rw-r--r--dev-perl/mod_perl/mod_perl-1.99.10.ebuild114
4 files changed, 141 insertions, 1 deletions
diff --git a/dev-perl/mod_perl/Manifest b/dev-perl/mod_perl/Manifest
index 4cb0fffc902e..f1167fc3c6ef 100644
--- a/dev-perl/mod_perl/Manifest
+++ b/dev-perl/mod_perl/Manifest
@@ -1,13 +1,14 @@
MD5 9eb488a8d217058474db6e04e22c62fa mod_perl-1.99.09.ebuild 3613
MD5 b04e594ce1aa3379787924322454aba5 mod_perl-1.27.ebuild 1416
MD5 0bf9316fb68b93b9bd9b72555e81b41b mod_perl-1.27-r2.ebuild 1821
-MD5 b161053955d40b4f73b92466428e8faf mod_perl-1.99.10.ebuild 3628
+MD5 ec207acb4dcbdb9f3f21e194acccb26b mod_perl-1.99.10.ebuild 3754
MD5 ca7b02d02b05f693bb730fd5eb8e6627 mod_perl-1.27-r4.ebuild 2196
MD5 026fbb84b447f735b4c86b46860f2afb mod_perl-1.99.08.ebuild 1244
MD5 58ceed38b57307fa4190170a23408524 mod_perl-1.27-r1.ebuild 1421
MD5 249d51b33f2a08cfa0a518b6fbe07a31 ChangeLog 3704
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
MD5 b8bea8f6d6e415b81c96ea0ff36478eb mod_perl-1.27-r3.ebuild 2031
+MD5 e749acb150e339917257be38febb568e files/mod_perl-1.99.10-nonukes.patch 777
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r1 65
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r2 65
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r3 65
diff --git a/dev-perl/mod_perl/files/digest-mod_perl-1.99.10 b/dev-perl/mod_perl/files/digest-mod_perl-1.99.10
new file mode 100644
index 000000000000..36c0d74770ac
--- /dev/null
+++ b/dev-perl/mod_perl/files/digest-mod_perl-1.99.10
@@ -0,0 +1 @@
+MD5 55345e460b5976b39da9aeb3b5a3b5db mod_perl-1.99_10.tar.gz 1063061
diff --git a/dev-perl/mod_perl/files/mod_perl-1.99.10-nonukes.patch b/dev-perl/mod_perl/files/mod_perl-1.99.10-nonukes.patch
new file mode 100644
index 000000000000..3615722aeebd
--- /dev/null
+++ b/dev-perl/mod_perl/files/mod_perl-1.99.10-nonukes.patch
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig 2003-10-30 16:38:27.000000000 -0800
++++ Makefile.PL 2003-10-30 16:38:37.000000000 -0800
+@@ -464,8 +464,8 @@
+
+ EOF
+
+- $string .= Apache::Test::install::nuke_Apache__test_target()
+- if APACHE_TEST_INSTALL();
++# $string .= Apache::Test::install::nuke_Apache__test_target()
++# if APACHE_TEST_INSTALL();
+
+ $string;
+ }
+@@ -476,8 +476,8 @@
+ ModPerl::MM::add_dep(\$string, pure_install => 'modperl_lib_install');
+ ModPerl::MM::add_dep(\$string, pure_install => 'modperl_xs_h_install');
+
+- ModPerl::MM::add_dep(\$string, pure_install => 'nuke_Apache__test')
+- if APACHE_TEST_INSTALL();
++# ModPerl::MM::add_dep(\$string, pure_install => 'nuke_Apache__test')
++# if APACHE_TEST_INSTALL();
+
+ $string;
+ }
diff --git a/dev-perl/mod_perl/mod_perl-1.99.10.ebuild b/dev-perl/mod_perl/mod_perl-1.99.10.ebuild
new file mode 100644
index 000000000000..8ed23f957492
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.99.10.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.99.10.ebuild,v 1.1 2003/10/31 00:58:38 rac Exp $
+
+inherit eutils
+
+MY_PV=$(echo $PV | perl -pe 's/\.([^.]+)$/_\1/')
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An embedded Perl interpreter for Apache2"
+SRC_URI="http://perl.apache.org/dist/${MY_P}.tar.gz"
+HOMEPAGE="http://perl.apache.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 amd64"
+IUSE=""
+SLOT="1"
+
+DEPEND="dev-lang/perl
+ =net-www/apache-2*
+ >=dev-perl/CGI-2.93
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # I am not entirely happy with this solution, but here's what's
+ # going on here if someone wants to take a stab at another
+ # approach. When userpriv compilation is off, then the make
+ # process drops to user "nobody" to run the test servers. This
+ # server is closed, and then the socket is rebound using
+ # SO_REUSEADDR. If the same user does this, there is no problem,
+ # and the socket may be rebound immediately. If a different user
+ # (yes, in my testing, even root) attempts to rebind, it fails.
+ # Since the "is the socket available yet" code and the
+ # second-batch bind call both run as root, this will fail.
+
+ # The upstream settings on my test machine cause the second batch
+ # of tests to fail, believing the socket to still be in use. I
+ # tried patching various parts to make them run as the user
+ # specified in $config->{vars}{user} using getpwnam, but found
+ # this patch to be fairly intrusive, because the userid must be
+ # restored and the patch must be applied to multiple places.
+
+ # For now, we will simply extend the timeout in hopes that in the
+ # non-userpriv case, the socket will clear from the kernel tables
+ # normally, and the tests will proceed.
+
+ # If anybody is still having problems, then commenting out "make
+ # test" below should allow the software to build properly.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.06
+
+ sed -i -e "s/sleep \$_/sleep \$_ << 2/" ${S}/Apache-Test/lib/Apache/TestServer.pm || die "problem editing TestServer.pm"
+
+ # this one is because of sandbox problems trying to uninstall test.pm
+
+ epatch ${FILESDIR}/${P}-nonukes.patch || die
+}
+
+src_compile() {
+ perl Makefile.PL \
+ PREFIX=${D}/usr \
+ MP_TRACE=1 \
+ MP_DEBUG=1 \
+ MP_AP_PREFIX=/usr \
+ MP_USE_DSO=1 \
+ MP_INST_APACHE2=1 \
+ MP_APXS=/usr/sbin/apxs2 \
+ CCFLAGS="${CFLAGS} -fPIC" \
+ INSTALLDIRS=vendor </dev/null || die
+
+ emake || die
+
+ # make test notes whether it is running as root, and drops
+ # privileges all the way to "nobody" if so, so we must adjust
+ # write permissions accordingly in this case.
+
+ if [ "`id -u`" == '0' ]; then
+ chown nobody:nobody ${WORKDIR}
+ chown nobody:nobody ${T}
+ fi
+
+ # these next two stanzas avoid sandbox problems with make test
+ # tell mod_cgid to make the socket here instead of /var/run/cgisock
+ echo -e "\nScriptSock logs/cgisock" >> ${S}/t/conf/extra.conf.in
+ echo -e "\nScriptSock logs/cgisock" >> ${S}/ModPerl-Registry/t/conf/extra.conf.in
+ # tell CGI.pm to create new tmpfiles in this directory
+ echo -e "\nSetEnv TMPDIR ${T}" >> ${S}/t/conf/extra.conf.in
+
+ # this does not || die because of bug 21325.
+
+ make test
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install \
+ MODPERL_AP_LIBEXECDIR=${D}/usr/lib/apache2-extramodules \
+ MODPERL_AP_INCLUDEDIR=${D}/usr/include/apache2 \
+ MP_INST_APACHE2=1 \
+ INSTALLDIRS=vendor || die
+
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/75_mod_perl.conf \
+ ${FILESDIR}/apache2-mod_perl-startup.pl
+
+ dodoc ${FILESDIR}/75_mod_perl.conf Changes \
+ INSTALL LICENSE README STATUS
+ cp -a docs ${D}/usr/share/doc/${PF}
+ cp -a todo ${D}/usr/share/doc/${PF}
+}