summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2005-12-18 01:44:50 +0000
committerLuca Longinotti <chtekk@gentoo.org>2005-12-18 01:44:50 +0000
commit68fcde0546a3165125600f24245524eeca3d2bcd (patch)
treed15c42ee371fb098465b8d79d0fe008009995f32 /dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild
parentVersion bump. (diff)
downloadhistorical-68fcde0546a3165125600f24245524eeca3d2bcd.tar.gz
historical-68fcde0546a3165125600f24245524eeca3d2bcd.tar.bz2
historical-68fcde0546a3165125600f24245524eeca3d2bcd.zip
Sync with overlay.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild')
-rw-r--r--dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild b/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild
new file mode 100644
index 000000000000..78998fa434f1
--- /dev/null
+++ b/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo-sqlite/pecl-pdo-sqlite-1.0.ebuild,v 1.1 2005/12/18 01:44:50 chtekk Exp $
+
+PHP_EXT_NAME="pdo_sqlite"
+PHP_EXT_PECL_PKG="PDO_SQLITE"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+DESCRIPTION="PHP Data Objects (PDO) Driver For SQLite Server."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-php5/pecl-pdo"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # if the user has compiled in PDO, he can't use this package
+ if built_with_use =${PHP_PKG} pdo ; then
+ eerror
+ eerror "You have built ${PHP_PKG} to use the bundled PDO support."
+ eerror "If you want to use the PECL PDO packages, you must rebuild"
+ eerror "your PHP with the 'pdo-external' USE flag instead."
+ eerror
+ die "PHP built to use bundled PDO support"
+ fi
+}