summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2009-08-11 17:11:32 +0000
committerHanno Boeck <hanno@gentoo.org>2009-08-11 17:11:32 +0000
commit0ad54ea877433b147464339ada87e4b3ebf518c2 (patch)
treed6a5f95e8dfa1fe51534fc5ae0cf3661d7f6c30f /dev-php5
parentRedo the namespace patch. (diff)
downloadhistorical-0ad54ea877433b147464339ada87e4b3ebf518c2.tar.gz
historical-0ad54ea877433b147464339ada87e4b3ebf518c2.tar.bz2
historical-0ad54ea877433b147464339ada87e4b3ebf518c2.zip
initial commit of pecl-ssh2
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-ssh2/ChangeLog10
-rw-r--r--dev-php5/pecl-ssh2/Manifest14
-rw-r--r--dev-php5/pecl-ssh2/metadata.xml5
-rw-r--r--dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild20
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-php5/pecl-ssh2/ChangeLog b/dev-php5/pecl-ssh2/ChangeLog
new file mode 100644
index 000000000000..72aa1c9ac8ce
--- /dev/null
+++ b/dev-php5/pecl-ssh2/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php5/pecl-ssh2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/ChangeLog,v 1.1 2009/08/11 17:11:32 hanno Exp $
+
+*pecl-ssh2-0.11.0 (11 Aug 2009)
+
+ 11 Aug 2009; Hanno Boeck <hanno@gentoo.org> +pecl-ssh2-0.11.0.ebuild,
+ +metadata.xml:
+ Initial commit of php bindings for libssh2.
+
diff --git a/dev-php5/pecl-ssh2/Manifest b/dev-php5/pecl-ssh2/Manifest
new file mode 100644
index 000000000000..e2ef1dca3ae2
--- /dev/null
+++ b/dev-php5/pecl-ssh2/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST ssh2-0.11.0.tgz 22884 RMD160 c0e156928450b9f41a8363a5730fba99e3956ca2 SHA1 4c8d1af81046e69db7b0d45de894b0f73a2d83c6 SHA256 3350adf6fc182ca871ddacfb75048015366c828bf54665dbbcb090b9229551c9
+EBUILD pecl-ssh2-0.11.0.ebuild 560 RMD160 aefdd4ebefdebaad7ffce7bcab80d4128bc1b651 SHA1 a62b436652a706af2b55ffea10b2def824e8c7c0 SHA256 d1004c12681c09b840925676751affe202fa589a7817bd9a824dd8141ec0bdf6
+MISC ChangeLog 377 RMD160 148be6a650e1e9d71f1b08e37303c6aec46bd444 SHA1 64d26dfb0580d21b0cc296ef1f1d9403fabd4d82 SHA256 0dbb791ae9d98c8424f62f6a23997ca5244504a2a105c3974fa1d19bda2b1cd8
+MISC metadata.xml 156 RMD160 a3a59cdc3ac33d711123b2d7e2b1deb2984aa101 SHA1 1f452f476317b4634c684eabfd8840d06d35b414 SHA256 f6d70434415ff7294f2a64e7870f32318c5fab9153fe63a58841b12d897da6ba
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqBpkAACgkQr2QksT29OyCT5QCfUKJXqKNmAHohppVVfLklufOP
++NAAmwSfInDycCxbHYOnI3CED7NQVXXN
+=7cPY
+-----END PGP SIGNATURE-----
diff --git a/dev-php5/pecl-ssh2/metadata.xml b/dev-php5/pecl-ssh2/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php5/pecl-ssh2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
new file mode 100644
index 000000000000..30b99bffba74
--- /dev/null
+++ b/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-ssh2/pecl-ssh2-0.11.0.ebuild,v 1.1 2009/08/11 17:11:32 hanno Exp $
+
+PHP_EXT_NAME="ssh2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README ChangeLog"
+
+inherit php-ext-pecl-r1
+
+DESCRIPTION="Provides bindings to the functions of libssh2 which implements the SSH2 protocol."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND=">=net-libs/libssh2-0.18"
+RDEPEND="${DEPEND}"
+
+need_php_by_category