summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-07-27 17:51:29 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-07-27 17:51:29 +0000
commit45c6580b25f27098d2d990bfe887f5cc4943fbb1 (patch)
treec00833ccdddbb76904eb9420362bf952e2ce0429 /dev-php
parentadd patch to fix access violation on some system. (diff)
downloadhistorical-45c6580b25f27098d2d990bfe887f5cc4943fbb1.tar.gz
historical-45c6580b25f27098d2d990bfe887f5cc4943fbb1.tar.bz2
historical-45c6580b25f27098d2d990bfe887f5cc4943fbb1.zip
Version bumped.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpgroupware/ChangeLog8
-rw-r--r--dev-php/phpgroupware/Manifest4
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.0021
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.16.002.ebuild54
4 files changed, 65 insertions, 2 deletions
diff --git a/dev-php/phpgroupware/ChangeLog b/dev-php/phpgroupware/ChangeLog
index 98248e8ce572..2d3d2dfce0e8 100644
--- a/dev-php/phpgroupware/ChangeLog
+++ b/dev-php/phpgroupware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpgroupware
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.26 2004/07/21 21:28:03 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.27 2004/07/27 17:51:29 mholzer Exp $
+
+*phpgroupware-0.9.16.002 (27 Jul 2004)
+
+ 27 Jul 2004; Martin Holzer <mholzer@gentoo.org>
+ phpgroupware-0.9.16.002.ebuild:
+ Version bumped.
*phpgroupware-0.9.16.001 (21 Jul 2004)
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index 7daa4eab7df9..4831f8ef4113 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,6 +1,8 @@
-MD5 d80e08fa5244fd8f4d4aee1097b1d23f ChangeLog 3280
+MD5 664a331cd05c51e1d6ecef89bc65cde5 ChangeLog 3423
MD5 34b376f52ca199fffb4e52b83169574a metadata.xml 156
MD5 372a2ced88e621c1de16940f951fa1f0 phpgroupware-0.9.16.001.ebuild 1569
MD5 868acd2e93fdfde59f34f64b199e5439 phpgroupware-0.9.16.000.ebuild 1570
+MD5 0afcf4d745cd7af9234139c8d8893eb2 phpgroupware-0.9.16.002.ebuild 1569
MD5 476589363905ff689b142486cc9e534c files/digest-phpgroupware-0.9.16.001 78
MD5 922ab954a67c17f0e1a566626098243a files/digest-phpgroupware-0.9.16.000 80
+MD5 2d079648289561daf7733bb66d312958 files/digest-phpgroupware-0.9.16.002 78
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.002 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.002
new file mode 100644
index 000000000000..b6ede76ed16e
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.16.002
@@ -0,0 +1 @@
+MD5 e53885fd3e1fd60b2ee587af281a7c02 phpgroupware-0.9.16.002.tar.bz2 17482130
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.16.002.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.16.002.ebuild
new file mode 100644
index 000000000000..ec6fdba9a5be
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.16.002.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.16.002.ebuild,v 1.1 2004/07/27 17:51:29 mholzer Exp $
+
+inherit webapp-apache
+
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="intranet/groupware tool and application framework"
+HOMEPAGE="http://www.phpgroupware.org/"
+SRC_URI="mirror://sourceforge/phpgroupware/${P}.tar.bz2"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa"
+
+RDEPEND=">=dev-php/mod_php-4.1"
+
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+ if [ -L ${HTTPD_ROOT}/${PN} ] ; then
+ ewarn "You need to unmerge your old ${PN} version first."
+ ewarn "${PN} will be installed into ${HTTPD_ROOT}/${PN}"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ webapp-detect || NO_WEBSERVER=1
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+
+ dodir ${destdir}
+ #cd ${WORKDIR}
+ cp -r . ${D}${destdir}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+ # Fix permissions
+ find ${D}${destdir} -type d | xargs chmod 755
+ find ${D}${destdir} -type f | xargs chmod 644
+ dohtml ${PN}/doc/en_US/html/admin/*.html
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at"
+ einfo "/usr/share/doc/${PF}/html/x62.html#AEN134"
+ einfo "to complete the install."
+ einfo "You need to add MySQL users and configure ${PN}"
+}