summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-07-26 11:56:41 +0000
committerTal Peer <coredumb@gentoo.org>2003-07-26 11:56:41 +0000
commitea083c32f4f9c945fcfc7800a6296f726a7c302b (patch)
tree9d8aff8d67f3afda54413e460c3b99b54cc70328 /dev-php
parentInitial import. (diff)
downloadhistorical-ea083c32f4f9c945fcfc7800a6296f726a7c302b.tar.gz
historical-ea083c32f4f9c945fcfc7800a6296f726a7c302b.tar.bz2
historical-ea083c32f4f9c945fcfc7800a6296f726a7c302b.zip
Initial import.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PECL-sqlite/Manifest3
-rw-r--r--dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild32
-rw-r--r--dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.01
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-php/PECL-sqlite/Manifest b/dev-php/PECL-sqlite/Manifest
index e44a1ae9b8f7..78123fe44928 100644
--- a/dev-php/PECL-sqlite/Manifest
+++ b/dev-php/PECL-sqlite/Manifest
@@ -1,2 +1,3 @@
-MD5 83828bbb2f9faa2e9bbaa698faefc00b PECL-sqlite-1.0.ebuild 599
+MD5 05624d63812a003281dba19dbf9e6f7b PECL-sqlite-1.0.ebuild 830
+MD5 48d9f41bb6b8ba594d5aeabe77659b73 ChangeLog 338
MD5 fab5ec940d737fe806ebb2cd43c97223 files/digest-PECL-sqlite-1.0 59
diff --git a/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild b/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
new file mode 100644
index 000000000000..c6516c51b58f
--- /dev/null
+++ b/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PECL-sqlite/PECL-sqlite-1.0.ebuild,v 1.1 2003/07/26 11:56:25 coredumb Exp $
+
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_NAME="sqlite"
+PHP_EXT_INI="yes"
+
+inherit php-ext-source
+
+DEPEND="${DEPEND} >=dev-db/sqlite-2.8.5"
+
+IUSE=""
+DESCRIPTION="PHP bindings for the SQLite database engine"
+HOMEPAGE="http://pear.php.net/SQLite"
+SLOT="0"
+MY_PN="SQLite"
+SRC_URI="http://pear.php.net/get/${MY_PN}-${PV}.tgz"
+S=${WORKDIR}/${MY_PN}-${PV}
+LICENSE="PHP"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+src_compile() {
+ #use the external library, not the bundled one
+ myconf="${myconf} --with-sqlite=/usr"
+ php-ext-source_src_compile
+}
+
+src_install() {
+ php-ext-source_src_install
+ dodoc CREDITS README TODO
+}
diff --git a/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0 b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0
new file mode 100644
index 000000000000..668759b24fc9
--- /dev/null
+++ b/dev-php/PECL-sqlite/files/digest-PECL-sqlite-1.0
@@ -0,0 +1 @@
+MD5 fabecdcdbeecd260cc05f90e4fcc79b8 SQLite-1.0.tgz 354024