summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-04 08:47:59 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-04 08:47:59 +0000
commitb2f255ac4e2be66b7c8bdb72041894288e737b94 (patch)
tree14e0f74d0838b401fdb3879d55bd78ea968f818d /dev-python/autopep8/autopep8-1.0.1.ebuild
parentStable for x86, wrt bug #507006 (diff)
downloadhistorical-b2f255ac4e2be66b7c8bdb72041894288e737b94.tar.gz
historical-b2f255ac4e2be66b7c8bdb72041894288e737b94.tar.bz2
historical-b2f255ac4e2be66b7c8bdb72041894288e737b94.zip
drop py2.6 add py3.4 pypy support tidy deps
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/autopep8/autopep8-1.0.1.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.0.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/autopep8/autopep8-1.0.1.ebuild b/dev-python/autopep8/autopep8-1.0.1.ebuild
index 847d15e1d887..51f912ed9b8c 100644
--- a/dev-python/autopep8/autopep8-1.0.1.ebuild
+++ b/dev-python/autopep8/autopep8-1.0.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.0.1.ebuild,v 1.1 2014/05/03 08:38:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.0.1.ebuild,v 1.2 2014/05/04 08:47:35 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1 vcs-snapshot
@@ -18,10 +18,10 @@ IUSE=""
DEPEND=">=dev-python/pep8-1.5.6[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND=">=dev-python/pep8-1.5.6[${PYTHON_USEDEP}]"
python_test() {
- "${PYTHON}" setup.py test || die
+ esetup.py test
}
pkg_postinst() {