summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-20 16:50:29 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-20 16:50:29 +0000
commit5cbb78ba81f7ba8799f0dadbbf2356a6457b723a (patch)
treead44d465c50b56045fed1e05cfe65dae581c63ef /dev-python/bottle/bottle-0.10.9.ebuild
parentadd version 4.9.5 for 4.9.5_p01 cannot function correctly, upstream bug http:... (diff)
downloadhistorical-5cbb78ba81f7ba8799f0dadbbf2356a6457b723a.tar.gz
historical-5cbb78ba81f7ba8799f0dadbbf2356a6457b723a.tar.bz2
historical-5cbb78ba81f7ba8799f0dadbbf2356a6457b723a.zip
Don't inherit eutils.eclass since it's not used, drop unnecessary dependecy on setuptools. Thanks to Arfrever for report
Package-Manager: portage-2.2.0_alpha104/cvs/Linux x86_64
Diffstat (limited to 'dev-python/bottle/bottle-0.10.9.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.10.9.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/bottle/bottle-0.10.9.ebuild b/dev-python/bottle/bottle-0.10.9.ebuild
index e70a783ae3f2..5a73afc1d7bd 100644
--- a/dev-python/bottle/bottle-0.10.9.ebuild
+++ b/dev-python/bottle/bottle-0.10.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.10.9.ebuild,v 1.1 2012/05/19 10:53:54 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.10.9.ebuild,v 1.2 2012/05/20 16:50:29 xarthisius Exp $
EAPI=4
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="*-jython"
-inherit distutils eutils
+inherit distutils
DESCRIPTION="A fast and simple micro-framework for small web-applications"
HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
@@ -20,8 +20,8 @@ IUSE=""
PYTHON_MODNAME=bottle.py
-RDEPEND="dev-python/simplejson"
-DEPEND="${RDEPEND} dev-python/setuptools"
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
src_prepare() {
distutils_src_prepare