summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2013-10-23 03:23:05 +0000
committerMatt Thode <prometheanfire@gentoo.org>2013-10-23 03:23:05 +0000
commita1e5d76668a9531b2ea623a560b527d7a0984682 (patch)
treec4e17a1724f18e5ace6a29eca5e311b878802b49 /dev-python/cmd2/cmd2-0.6.7.ebuild
parentadding cinder havana support (diff)
downloadhistorical-a1e5d76668a9531b2ea623a560b527d7a0984682.tar.gz
historical-a1e5d76668a9531b2ea623a560b527d7a0984682.tar.bz2
historical-a1e5d76668a9531b2ea623a560b527d7a0984682.zip
update of cmd2 (yay better pyparsing)
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x2471EB3E40AC5AC3
Diffstat (limited to 'dev-python/cmd2/cmd2-0.6.7.ebuild')
-rw-r--r--dev-python/cmd2/cmd2-0.6.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cmd2/cmd2-0.6.7.ebuild b/dev-python/cmd2/cmd2-0.6.7.ebuild
new file mode 100644
index 000000000000..c5f6fc3a1c6a
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.6.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cmd2/cmd2-0.6.7.ebuild,v 1.1 2013/10/23 03:22:56 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://bitbucket.org/catherinedevlin/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+#python_prepare_all() {
+# # Remove broken pyparsing dep.
+# # https://bitbucket.org/catherinedevlin/cmd2/pull-request/3
+# sed -i -e '/= install_requires/d' setup.py || die
+#
+# distutils-r1_python_prepare_all
+#}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ "${PYTHON}" -m cmd2 -v || die "Tests fail with ${EPYTHON}"
+}