summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-28 19:35:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-28 19:35:17 +0000
commit5ba80c55bbc1fe2df59738184ecd2d235ab5cd42 (patch)
treeb34b9533f5fba594f9f179915b7507fa1829d85d /dev-python/dingus/dingus-0.3.4.ebuild
parentMasked dev-python/xsv for removal wrt #396497 (diff)
downloadhistorical-5ba80c55bbc1fe2df59738184ecd2d235ab5cd42.tar.gz
historical-5ba80c55bbc1fe2df59738184ecd2d235ab5cd42.tar.bz2
historical-5ba80c55bbc1fe2df59738184ecd2d235ab5cd42.zip
Reorder variables, don't install doc files straight to /usr wrt #413769 by James Rowe <jnrowe@gmail.com>
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'dev-python/dingus/dingus-0.3.4.ebuild')
-rw-r--r--dev-python/dingus/dingus-0.3.4.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/dingus/dingus-0.3.4.ebuild b/dev-python/dingus/dingus-0.3.4.ebuild
index 4aafccc5b85c..8f73fe7e1717 100644
--- a/dev-python/dingus/dingus-0.3.4.ebuild
+++ b/dev-python/dingus/dingus-0.3.4.ebuild
@@ -1,24 +1,29 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dingus/dingus-0.3.4.ebuild,v 1.1 2012/04/18 16:19:30 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dingus/dingus-0.3.4.ebuild,v 1.2 2012/04/28 19:35:17 xarthisius Exp $
EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS=1
RESTRICT_PYTHON_ABIS="3.*"
+
inherit distutils
DESCRIPTION="A record-then-assert mocking library"
HOMEPAGE="http://pypi.python.org/pypi/dingus/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
LICENSE="MIT"
SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DEPEND="dev-python/setuptools"
RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools"
+
+src_prepare() {
+ sed -i -e '/data_files/d' setup.py || die #413769
+ distutils_src_prepare
+}