summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-25 05:11:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-25 05:11:21 +0000
commitd6292db9bc841e0652e0b2ba11dad0d51f4ab606 (patch)
tree3c24c25b8299aa3cbd706b6663e5186e1f476145 /dev-python/eventlet/eventlet-0.9.16.ebuild
parentInitial import, borrowed from the hyves openstack-overlay (diff)
downloadhistorical-d6292db9bc841e0652e0b2ba11dad0d51f4ab606.tar.gz
historical-d6292db9bc841e0652e0b2ba11dad0d51f4ab606.tar.bz2
historical-d6292db9bc841e0652e0b2ba11dad0d51f4ab606.zip
Initial import, borrowed from the hyves openstack-overlay
Package-Manager: portage-2.2.0_alpha141/cvs/Linux x86_64
Diffstat (limited to 'dev-python/eventlet/eventlet-0.9.16.ebuild')
-rw-r--r--dev-python/eventlet/eventlet-0.9.16.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/eventlet/eventlet-0.9.16.ebuild b/dev-python/eventlet/eventlet-0.9.16.ebuild
new file mode 100644
index 000000000000..039c2e9ead46
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.9.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/eventlet/eventlet-0.9.16.ebuild,v 1.1 2012/10/25 05:10:35 patrick Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="http://pypi.python.org/pypi/eventlet"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ test? ( dev-python/greenlet )"
+RDEPEND="dev-python/greenlet"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake -C doc html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r doc/_build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}