summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-16 07:11:55 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-16 07:11:55 +0000
commitb9ef10f794fe8756078db893b98bd8d390730f26 (patch)
treeb341a51c523b988b0f3f4edee7b052304ee54235 /dev-python/fudge/fudge-1.1.0.ebuild
parentStable for x86, wrt bug #550658 (diff)
downloadhistorical-b9ef10f794fe8756078db893b98bd8d390730f26.tar.gz
historical-b9ef10f794fe8756078db893b98bd8d390730f26.tar.bz2
historical-b9ef10f794fe8756078db893b98bd8d390730f26.zip
bump, tidy
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/fudge/fudge-1.1.0.ebuild')
-rw-r--r--dev-python/fudge/fudge-1.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/fudge/fudge-1.1.0.ebuild b/dev-python/fudge/fudge-1.1.0.ebuild
new file mode 100644
index 000000000000..217a6fa37884
--- /dev/null
+++ b/dev-python/fudge/fudge-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fudge/fudge-1.1.0.ebuild,v 1.1 2015/06/16 07:11:29 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Replace real objects with fakes (mocks, stubs, etc) while testing"
+HOMEPAGE="http://farmdev.com/projects/fudge/ http://pypi.python.org/pypi/fudge"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}