summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Lauwers <blauwers@gentoo.org>2002-12-17 21:18:25 +0000
committerBart Lauwers <blauwers@gentoo.org>2002-12-17 21:18:25 +0000
commit9b89c35c33881cecfad91d3d1aa59ba3581a6b0e (patch)
tree48d5e19dc6d57828506f620ecbff0decfc92a0ec /dev-python/gadfly
parentxemacs packages digests (diff)
downloadhistorical-9b89c35c33881cecfad91d3d1aa59ba3581a6b0e.tar.gz
historical-9b89c35c33881cecfad91d3d1aa59ba3581a6b0e.tar.bz2
historical-9b89c35c33881cecfad91d3d1aa59ba3581a6b0e.zip
Initial import per Bug #8359
Diffstat (limited to 'dev-python/gadfly')
-rw-r--r--dev-python/gadfly/ChangeLog8
-rw-r--r--dev-python/gadfly/files/digest-gadfly-1.0.01
-rw-r--r--dev-python/gadfly/gadfly-1.0.0.ebuild29
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/gadfly/ChangeLog b/dev-python/gadfly/ChangeLog
new file mode 100644
index 000000000000..fa956fa2e50a
--- /dev/null
+++ b/dev-python/gadfly/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/gadfly
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gadfly/ChangeLog,v 1.1 2002/12/17 21:18:25 blauwers Exp $
+
+*gadfly-1.0.0 (17 Dec 2002)
+
+ 17 Dec 2002; B.Lauwers <blauwers@gentoo.org> :
+ Initial submit per #8359, thanks Ollie Rutherfurd!
diff --git a/dev-python/gadfly/files/digest-gadfly-1.0.0 b/dev-python/gadfly/files/digest-gadfly-1.0.0
new file mode 100644
index 000000000000..360dbcc37037
--- /dev/null
+++ b/dev-python/gadfly/files/digest-gadfly-1.0.0
@@ -0,0 +1 @@
+MD5 8dc11575e4d8042058f6ad11b32a8641 gadfly-1.0.0.tar.gz 309201
diff --git a/dev-python/gadfly/gadfly-1.0.0.ebuild b/dev-python/gadfly/gadfly-1.0.0.ebuild
new file mode 100644
index 000000000000..1a527e74cba2
--- /dev/null
+++ b/dev-python/gadfly/gadfly-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gadfly/gadfly-1.0.0.ebuild,v 1.1 2002/12/17 21:18:25 blauwers Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gadfly is a relational database system implemented in Python."
+SRC_URI="mirror://sourceforge/gadfly/${P}.tar.gz"
+HOMEPAGE="http://gadfly.sourceforge.net/"
+
+DEPEND="virtual/python"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="BSD"
+
+src_compile() {
+ python setup.py build || die "gadfly compilation failed"
+ cd kjbuckets
+ python setup.py build || die "kjbuckets compilation failed"
+ cd ..
+}
+
+src_install() {
+ python setup.py install --root=${D} || die
+ cd kjbuckets
+ python setup.py install --root=${D} || die
+ cd ..
+ dodoc *.txt doc/*.txt
+}