summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-19 21:09:46 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-19 21:09:46 +0000
commit33df476ceb4f569f6494c7250e4a269950c7c850 (patch)
tree50d32e4b34cc18b2052f7e2d1b37ab75628ec64d /dev-python/gnome-python-desktop-base
parentNew version for GNOME 2.24. (diff)
downloadhistorical-33df476ceb4f569f6494c7250e4a269950c7c850.tar.gz
historical-33df476ceb4f569f6494c7250e4a269950c7c850.tar.bz2
historical-33df476ceb4f569f6494c7250e4a269950c7c850.zip
New version for GNOME 2.24.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64
Diffstat (limited to 'dev-python/gnome-python-desktop-base')
-rw-r--r--dev-python/gnome-python-desktop-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.24.0.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/gnome-python-desktop-base/ChangeLog b/dev-python/gnome-python-desktop-base/ChangeLog
index 59550f922b79..975a8ab67488 100644
--- a/dev-python/gnome-python-desktop-base/ChangeLog
+++ b/dev-python/gnome-python-desktop-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-desktop-base
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.1 2008/09/14 16:27:45 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.2 2008/10/19 21:09:03 eva Exp $
+
+*gnome-python-desktop-base-2.24.0 (19 Oct 2008)
+
+ 19 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-python-desktop-base-2.24.0.ebuild:
+ New version for GNOME 2.24.
*gnome-python-desktop-base-2.22.0 (14 Sep 2008)
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.24.0.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.24.0.ebuild
new file mode 100644
index 000000000000..ef3b09f0ec9f
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.24.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.24.0.ebuild,v 1.1 2008/10/19 21:09:03 eva Exp $
+
+inherit eutils gnome2 versionator
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-desktop"
+PVP="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# From the gnome-python-desktop eclass
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10.3
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ !<dev-python/gnome-python-extras-2.13
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog INSTALL* MAINTAINERS NEWS README"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}