summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-01-08 21:48:01 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-01-08 21:48:01 +0000
commit7a95fa71336fdbfd345061e5925df867149cf75f (patch)
tree3ef30143a471ae040561d119eb16834c623d9fbb /dev-python/gnome-python-extras
parentversion bump. (diff)
downloadhistorical-7a95fa71336fdbfd345061e5925df867149cf75f.tar.gz
historical-7a95fa71336fdbfd345061e5925df867149cf75f.tar.bz2
historical-7a95fa71336fdbfd345061e5925df867149cf75f.zip
version bump, remove gda patch since python 2.4 is stable now.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-python/gnome-python-extras')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog10
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.11
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.12.1.ebuild78
3 files changed, 87 insertions, 2 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index c374f1dba7af..3481a9145497 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-extras
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.14 2005/09/21 21:42:50 dang Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.15 2006/01/08 21:48:01 allanonjl Exp $
+
+*gnome-python-extras-2.12.1 (08 Jan 2006)
+
+ 08 Jan 2006; John N. Laliberte <allanonjl@gentoo.org>
+ +gnome-python-extras-2.12.1.ebuild:
+ version bump, remove gda patch since python 2.4 is stable now.
*gnome-python-extras-2.12.0 (21 Sep 2005)
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1
new file mode 100644
index 000000000000..6ce5e7b2101f
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.12.1
@@ -0,0 +1 @@
+MD5 62a3d8bb5bd5c1696c7200c001ea34f2 gnome-python-extras-2.12.1.tar.bz2 476483
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.12.1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.12.1.ebuild
new file mode 100644
index 000000000000..e0f9f34d9b4e
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.12.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.12.1.ebuild,v 1.1 2006/01/08 21:48:01 allanonjl Exp $
+
+inherit eutils gnome2 python
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc firefox mozilla"
+
+RDEPEND=">=dev-lang/python-2.3
+ >=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/gnome-python-2.10
+ >=dev-python/pygtk-2.4
+ =gnome-extra/libgtkhtml-2.6*
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=x11-libs/gtksourceview-1.1.90
+ >=gnome-base/gnome-panel-2.10
+ >=x11-libs/libwnck-2.9.92
+ firefox? ( >=www-client/mozilla-firefox-1.0 )
+ !firefox? ( mozilla? ( >=www-client/mozilla-1.2 ) )
+ >=gnome-base/libgtop-2.9.5
+ >=gnome-extra/nautilus-cd-burner-2.11.1
+ >=app-text/gtkspell-2
+ >=gnome-base/gconf-2.10
+ media-video/totem
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/scrollkeeper
+ "
+
+G2CONF=""
+USE_DESTDIR="1"
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+src_compile() {
+
+ # only controls linking, can't disable w/o a patch :)
+ use firefox && G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ if ! use firefox; then
+ use mozilla && G2CONF="${G2CONF} --with-gtkmozembed=mozilla"
+ fi
+
+ if ! use firefox && ! use mozilla; then
+ G2CONF="${G2CONF} --without-gtkmozembed"
+ fi
+
+ gnome2_src_configure ${G2CONF}
+
+ emake || die "make failed!"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}