summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Thode <prometheanfire@gentoo.org>2013-01-01 08:12:08 +0000
committerMatt Thode <prometheanfire@gentoo.org>2013-01-01 08:12:08 +0000
commit7cb9853b5f618c758556a17dc4361b6b1a85a4ee (patch)
tree18dfa3b85d6f925b5671c995440c56d7538560e2 /dev-python/hgtools/hgtools-2.0.2.ebuild
parentupdate to eapi5 and distutils-r1 (diff)
downloadhistorical-7cb9853b5f618c758556a17dc4361b6b1a85a4ee.tar.gz
historical-7cb9853b5f618c758556a17dc4361b6b1a85a4ee.tar.bz2
historical-7cb9853b5f618c758556a17dc4361b6b1a85a4ee.zip
update to eapi5 and distutils-r1
Package-Manager: portage-2.1.11.31/cvs/Linux x86_64 Manifest-Sign-Key: 0x2471EB3E40AC5AC3
Diffstat (limited to 'dev-python/hgtools/hgtools-2.0.2.ebuild')
-rw-r--r--dev-python/hgtools/hgtools-2.0.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/hgtools/hgtools-2.0.2.ebuild b/dev-python/hgtools/hgtools-2.0.2.ebuild
index 7671e9ac342f..0e05094ad10c 100644
--- a/dev-python/hgtools/hgtools-2.0.2.ebuild
+++ b/dev-python/hgtools/hgtools-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/hgtools/hgtools-2.0.2.ebuild,v 1.3 2013/01/01 06:52:46 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/hgtools/hgtools-2.0.2.ebuild,v 1.4 2013/01/01 08:12:01 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
@@ -15,6 +15,11 @@ SRC_URI="mirror://pypi/h/${MY_PN}/${MY_PN}-${PV}.zip"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+IUSE="test"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/py )"
RDEPEND=""
+
+python_test() {
+ "${PYTHON}" setup.py test
+}