summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-02-26 13:27:05 +0000
commit1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae (patch)
treee5858b1bc23fa91ef29bbd90813bf2a028bdb3f9 /dev-python/libgnome-python
parentsparc stable (bug 351487) (diff)
downloadhistorical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.gz
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.tar.bz2
historical-1dad35e94a2e8cab32df6bb37c33cb4c9bd069ae.zip
Add missing eclass variables for proper python-updater behavior, bug #344833. Clean up old revision.
Package-Manager: portage-2.2.0_alpha24/cvs/Linux x86_64
Diffstat (limited to 'dev-python/libgnome-python')
-rw-r--r--dev-python/libgnome-python/ChangeLog7
-rw-r--r--dev-python/libgnome-python/libgnome-python-2.28.0.ebuild28
-rw-r--r--dev-python/libgnome-python/libgnome-python-2.28.1.ebuild5
3 files changed, 10 insertions, 30 deletions
diff --git a/dev-python/libgnome-python/ChangeLog b/dev-python/libgnome-python/ChangeLog
index 127045e47280..cf294dd8d0d3 100644
--- a/dev-python/libgnome-python/ChangeLog
+++ b/dev-python/libgnome-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libgnome-python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/ChangeLog,v 1.35 2011/01/30 19:47:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/ChangeLog,v 1.36 2011/02/26 13:20:08 eva Exp $
+
+ 26 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ -libgnome-python-2.28.0.ebuild, libgnome-python-2.28.1.ebuild:
+ Add missing eclass variables for proper python-updater behavior, bug #344833.
+ Clean up old revision.
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> libgnome-python-2.28.1.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #348987
diff --git a/dev-python/libgnome-python/libgnome-python-2.28.0.ebuild b/dev-python/libgnome-python/libgnome-python-2.28.0.ebuild
deleted file mode 100644
index fc3500f8e353..000000000000
--- a/dev-python/libgnome-python/libgnome-python-2.28.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/libgnome-python-2.28.0.ebuild,v 1.8 2010/09/08 09:39:29 ranger Exp $
-
-GCONF_DEBUG="no"
-
-G_PY_PN="gnome-python"
-G_PY_BINDINGS="gnome gnomeui"
-
-inherit gnome-python-common
-
-DESCRIPTION="Python bindings for essential GNOME libraries"
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="examples"
-
-RDEPEND=">=gnome-base/libgnome-2.24.1
- >=gnome-base/libgnomeui-2.24.0
- >=dev-python/pyorbit-2.24.0
- >=dev-python/libbonobo-python-${PV}
- >=dev-python/gnome-vfs-python-${PV}
- >=dev-python/libgnomecanvas-python-${PV}
- !<dev-python/gnome-python-2.22.1"
-DEPEND="${RDEPEND}"
-
-EXAMPLES="examples/*
- examples/popt/*"
diff --git a/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild b/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild
index 8da6a0fdf6dc..03d0558d20c7 100644
--- a/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild
+++ b/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild
@@ -1,11 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild,v 1.8 2011/01/30 19:47:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libgnome-python/libgnome-python-2.28.1.ebuild,v 1.9 2011/02/26 13:20:08 eva Exp $
GCONF_DEBUG="no"
G_PY_PN="gnome-python"
G_PY_BINDINGS="gnome gnomeui"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
inherit gnome-python-common