summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-05-22 21:22:54 +0000
committerIan Delaney <idella4@gentoo.org>2013-05-22 21:22:54 +0000
commitba06beaf935a07da395af7d11b5fb72aea40a01f (patch)
treedfd24abe8c71471973e057842ecfab781057f86d /dev-python/lxml/lxml-3.2.1.ebuild
parentclean up (diff)
downloadhistorical-ba06beaf935a07da395af7d11b5fb72aea40a01f.tar.gz
historical-ba06beaf935a07da395af7d11b5fb72aea40a01f.tar.bz2
historical-ba06beaf935a07da395af7d11b5fb72aea40a01f.zip
Adjust -3.2.1.ebuild to depend on beautifulsoup-3, beatufulsoup3 added to IUSE
Package-Manager: portage-2.1.11.62/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/lxml/lxml-3.2.1.ebuild')
-rw-r--r--dev-python/lxml/lxml-3.2.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/lxml/lxml-3.2.1.ebuild b/dev-python/lxml/lxml-3.2.1.ebuild
index 1e1cce88dd6e..f0b090fe8131 100644
--- a/dev-python/lxml/lxml-3.2.1.ebuild
+++ b/dev-python/lxml/lxml-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.1 2013/05/14 22:39:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.2 2013/05/22 21:22:23 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -13,13 +13,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD ElementTree GPL-2 PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd \
+ ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="beautifulsoup3 doc examples +threads"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
RDEPEND=">=dev-libs/libxml2-2.7.2
>=dev-libs/libxslt-1.1.15
- dev-python/beautifulsoup[${PYTHON_USEDEP}]"
+ beautifulsoup3? (
+ python_targets_python2_6? ( dev-python/beautifulsoup:python-2[python_targets_python2_6] )
+ python_targets_python2_7? ( dev-python/beautifulsoup:python-2[python_targets_python2_7] )
+ python_targets_python3_1? ( dev-python/beautifulsoup:python-3[python_targets_python3_1] )
+ python_targets_python3_2? ( dev-python/beautifulsoup:python-3[python_targets_python3_2] )
+ python_targets_python3_3? ( dev-python/beautifulsoup:python-3[python_targets_python3_3] )
+ )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
# lxml tarball contains files pregenerated by Cython.