summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-11-23 12:01:09 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-11-23 12:01:09 +0000
commit0ae2108466c70a3d7c6cca783b558361a3b1e95a (patch)
treea9c7266841cb0a3b04fdbe647be85c241091a8f8 /dev-python/m2crypto
parentversion bump. should fix openssl/python-2.3 problems (#33971) (diff)
downloadhistorical-0ae2108466c70a3d7c6cca783b558361a3b1e95a.tar.gz
historical-0ae2108466c70a3d7c6cca783b558361a3b1e95a.tar.bz2
historical-0ae2108466c70a3d7c6cca783b558361a3b1e95a.zip
version bump. should fix openssl/python-2.3 problems (#33971)
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest4
-rw-r--r--dev-python/m2crypto/files/digest-m2crypto-0.121
-rw-r--r--dev-python/m2crypto/m2crypto-0.12.ebuild27
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index a39610639e8e..5850561378ad 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,6 +1,6 @@
-MD5 67dd99c495b3dea59ea7ad9422310d8f ChangeLog 444
+MD5 3e07f4fb46e323ad48cd306d61e35572 ChangeLog 617
MD5 4e42332f0a8f01a601341111af347827 m2crypto-0.07_alpha3.ebuild 761
-MD5 825813b1c15f98f82914adde2ad197d4 m2crypto-0.12.ebuild 721
+MD5 a1c66ad3ceb6fe6b6ce840a65ad79720 m2crypto-0.12.ebuild 759
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 7601c8dba6f5d47b6abd298e4aa754c1 files/digest-m2crypto-0.07_alpha3 68
MD5 7861e3954b04c975b4c51806c167389b files/digest-m2crypto-0.12 62
diff --git a/dev-python/m2crypto/files/digest-m2crypto-0.12 b/dev-python/m2crypto/files/digest-m2crypto-0.12
new file mode 100644
index 000000000000..315bbc6ff56f
--- /dev/null
+++ b/dev-python/m2crypto/files/digest-m2crypto-0.12
@@ -0,0 +1 @@
+MD5 4e93a071e3abbf2bb2177d52583c3e0f m2crypto-0.12.zip 397229
diff --git a/dev-python/m2crypto/m2crypto-0.12.ebuild b/dev-python/m2crypto/m2crypto-0.12.ebuild
new file mode 100644
index 000000000000..a37dd1260325
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/m2crypto/m2crypto-0.12.ebuild,v 1.1 2003/11/23 12:01:04 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="A python wrapper for the OpenSSL crypto library"
+HOMEPAGE="http://www.post1.com/home/ngps/m2/"
+SRC_URI="http://sandbox.rulemaker.net/ngps/Dist/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.7"
+
+PYTHON_MODNAME="M2Crypto"
+
+src_install () {
+ DOCS="README SWIG BUGS CHANGES STORIES LICENCE"
+ distutils_src_install
+ # can't dodoc, doesn't handle subdirs
+ dodir /usr/share/doc/${PF}/example
+ cp -a demo/* ${D}/usr/share/doc/${PF}/example
+ dohtml -r doc/*
+}