summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2005-12-07 17:48:54 +0000
committerMarien Zwart <marienz@gentoo.org>2005-12-07 17:48:54 +0000
commitb58d273a6936decea7484c6ea31e59eeceab4e0d (patch)
tree023604f63c542c781610bed989426147c7ec8ce0 /dev-python/matplotlib/files
parentNow the patch is applied (diff)
downloadhistorical-b58d273a6936decea7484c6ea31e59eeceab4e0d.tar.gz
historical-b58d273a6936decea7484c6ea31e59eeceab4e0d.tar.bz2
historical-b58d273a6936decea7484c6ea31e59eeceab4e0d.zip
Fix insinfo / insinto typo in all versions. Version bump (bug #105443), dropping ~ppc and ~amd64 keywords because new deps have not been keyworded yet (bug #114776)
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-python/matplotlib/files')
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.851
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.85 b/dev-python/matplotlib/files/digest-matplotlib-0.85
new file mode 100644
index 000000000000..104ce8e8e71c
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.85
@@ -0,0 +1 @@
+MD5 4890ef6bd7a1a83acf579d4cbb6d237c matplotlib-0.85.tar.gz 2737883
diff --git a/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch b/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch
new file mode 100644
index 000000000000..05f2fd9a14a6
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.85-no-autodetect.patch
@@ -0,0 +1,53 @@
+--- matplotlib-0.84-orig/setup.py 2005-11-25 10:37:14.000000000 +0100
++++ matplotlib-0.84/setup.py 2005-11-25 11:51:46.000000000 +0100
+@@ -165,45 +165,19 @@
+ build_enthought(ext_modules, packages)
+
+ if BUILD_GTK:
+- try:
+- import gtk
+- except ImportError:
+- print 'GTK requires pygtk'
+- BUILD_GTK=0
+- except RuntimeError:
+- print 'pygtk present but import failed'
++ build_gdk(ext_modules, packages, NUMERIX)
+
+-if BUILD_GTK:
+- build_gdk(ext_modules, packages, NUMERIX)
+-
+-if BUILD_GTKAGG:
+- try:
+- import gtk
+- except ImportError:
+- print 'GTKAgg requires pygtk'
+- BUILD_GTKAGG=0
+- except RuntimeError:
+- print 'pygtk present but import failed'
+ if BUILD_GTKAGG:
+ BUILD_AGG = 1
+ build_gtkagg(ext_modules, packages, NUMERIX)
+
+ if BUILD_TKAGG:
+- try: import Tkinter
+- except ImportError: print 'TKAgg requires TkInter'
+- else:
+- BUILD_AGG = 1
+- build_tkagg(ext_modules, packages, NUMERIX)
++ BUILD_AGG = 1
++ build_tkagg(ext_modules, packages, NUMERIX)
+
+ if BUILD_WXAGG:
+- try: import wxPython
+- except ImportError:
+- if BUILD_WXAGG != 'auto':
+- print 'WXAgg\'s accelerator requires wxPython'
+- BUILD_WXAGG = 0
+- else:
+- BUILD_AGG = 1
+- build_wxagg(ext_modules, packages, NUMERIX,
++ BUILD_AGG = 1
++ build_wxagg(ext_modules, packages, NUMERIX,
+ not (isinstance(BUILD_WXAGG, str) # don't about if BUILD_WXAGG
+ and BUILD_WXAGG.lower() == 'auto')) # is "auto"
+