summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-18 15:58:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-18 15:58:06 +0000
commit02c8d4553cc23500219db544a41b676595856c95 (patch)
treefa9fc35651ee97b8bccc660d7109e7706142fd6c /dev-python/mechanize
parentVersion bump. (diff)
downloadhistorical-02c8d4553cc23500219db544a41b676595856c95.tar.gz
historical-02c8d4553cc23500219db544a41b676595856c95.tar.bz2
historical-02c8d4553cc23500219db544a41b676595856c95.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/mechanize')
-rw-r--r--dev-python/mechanize/files/mechanize-0.1.11-python-2.7.patch17
-rw-r--r--dev-python/mechanize/mechanize-0.1.11.ebuild50
-rw-r--r--dev-python/mechanize/mechanize-0.2.0.ebuild48
3 files changed, 0 insertions, 115 deletions
diff --git a/dev-python/mechanize/files/mechanize-0.1.11-python-2.7.patch b/dev-python/mechanize/files/mechanize-0.1.11-python-2.7.patch
deleted file mode 100644
index 1b7294f22673..000000000000
--- a/dev-python/mechanize/files/mechanize-0.1.11-python-2.7.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- test-tools/testprogram.py
-+++ test-tools/testprogram.py
-@@ -10,8 +10,12 @@
- import sys
- import time
- import traceback
--from unittest import defaultTestLoader, TextTestRunner, TestSuite, TestCase, \
-- _TextTestResult
-+from unittest import defaultTestLoader, TextTestRunner, TestSuite, TestCase
-+try:
-+ # Python 2.7 and >=3.2
-+ from unittest.runner import _TextTestResult
-+except ImportError:
-+ from unittest import _TextTestResult
-
-
- class ServerStartupError(Exception):
diff --git a/dev-python/mechanize/mechanize-0.1.11.ebuild b/dev-python/mechanize/mechanize-0.1.11.ebuild
deleted file mode 100644
index 475651c91071..000000000000
--- a/dev-python/mechanize/mechanize-0.1.11.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.1.11.ebuild,v 1.8 2010/02/14 18:48:41 armin76 Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
-SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND=">=dev-python/clientform-0.2.7"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="0.1-changes.txt"
-
-src_prepare() {
- # Use distutils instead of setuptools.
- # (This can't be removed in the same ${PV} due to file->directory replacement.)
- sed -e 's/not hasattr(sys, "version_info")/True/' -i setup.py || die "sed in setup.py failed"
-
- # We don't run coverage tests or functional_tests
- # which access the network, just doctests and unit tests
- sed -e '/import coverage/d' -i test.py || die "sed in test.py failed"
-
- epatch "${FILESDIR}/${P}-python-2.7.patch"
-}
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- # Remove some files to prevent distutils_src_install from installing them.
- dohtml *.html
- rm -f README.html*
-
- distutils_src_install
-}
diff --git a/dev-python/mechanize/mechanize-0.2.0.ebuild b/dev-python/mechanize/mechanize-0.2.0.ebuild
deleted file mode 100644
index b01937dbedb9..000000000000
--- a/dev-python/mechanize/mechanize-0.2.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.2.0.ebuild,v 1.4 2010/06/01 09:03:49 phajdan.jr Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="Stateful programmatic web browsing in Python"
-HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ http://pypi.python.org/pypi/mechanize"
-SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
-
-LICENSE="|| ( BSD ZPL )"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-DOCS="docs/*.txt"
-
-src_prepare() {
- # Use distutils instead of setuptools.
- # (This can't be removed in the same ${PV} due to file->directory replacement.)
- sed -e 's/not hasattr(sys, "version_info")/True/' -i setup.py || die "sed in setup.py failed"
-
- # We don't run coverage tests or functional_tests
- # which access the network, just doctests and unit tests
- sed -e '/import coverage/d' -i test.py || die "sed in test.py failed"
-}
-
-src_test() {
- testing() {
- # ignore warnings http://github.com/jjlee/mechanize/issues/issue/13
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" -Wignore test.py
- }
- python_execute_function testing
-}
-
-src_install() {
- # Fix some paths.
- sed -i -e 's:../styles/:styles/:g' docs/html/*
- dohtml -r docs/html/ docs/styles
- distutils_src_install
-}