summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 09:13:52 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 09:13:52 +0000
commit7b62bd28e1c404cfda99a930bd27e131943cd516 (patch)
treee7444bf17d73b71a02772707a4ab4e9967599ce1 /dev-python/mod_python
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-7b62bd28e1c404cfda99a930bd27e131943cd516.tar.gz
historical-7b62bd28e1c404cfda99a930bd27e131943cd516.tar.bz2
historical-7b62bd28e1c404cfda99a930bd27e131943cd516.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/mod_python-2.7.8.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/mod_python/mod_python-2.7.8.ebuild b/dev-python/mod_python/mod_python-2.7.8.ebuild
index 884041a504a6..931bb23fe004 100644
--- a/dev-python/mod_python/mod_python-2.7.8.ebuild
+++ b/dev-python/mod_python/mod_python-2.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.2 2002/11/06 15:02:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-2.7.8.ebuild,v 1.3 2002/11/17 09:13:52 vapier Exp $
DESCRIPTION="Python module for Apache"
SRC_URI="http://www.modpython.org/dist/${P}.tgz"
@@ -9,6 +9,7 @@ HOMEPAGE="http://www.modpython.org/"
LICENSE="AS-IS"
KEYWORDS="~x86"
SLOT="0"
+
DEPEND=">=net-www/apache-1.3.26-r2
dev-lang/python"
@@ -27,10 +28,7 @@ src_compile() {
echo 'echo "configure done"' >> configure
export OPTFLAGS="`/usr/sbin/apxs -q CFLAGS`"
- ./configure \
- --with-apxs=/usr/sbin/apxs \
- --prefix=/usr \
- --host=${CHOST} || die "configure failed"
+ econf --with-apxs=/usr/sbin/apxs
cp Makefile Makefile.orig
sed -e 's/LIBEXECDIR=\/usr\/lib\/apache/LIBEXECDIR=${D}\/usr\/lib\/apache-extramodules/' \
@@ -42,14 +40,13 @@ src_compile() {
sed -e 's/CFLAGS=$(OPT) $(INCLUDES)/CFLAGS=$(OPT) $(INCLUDES) -DEAPI -O0/' \
Makefile.orig > Makefile
-
emake || die "emake failed"
}
src_install() {
- mkdir -p ${D}/usr/lib/apache-extramodules
- mkdir ${D}/usr/lib/python2.2
- mkdir -p /etc/apache/conf/addon-modules
+ dodir /usr/lib/apache-extramodules
+ dodir /usr/lib/python2.2
+ dodir /etc/apache/conf/addon-modules
# compileall.py is needed or make install will fail
cp /usr/lib/python2.2/compileall.py ${D}usr/lib/python2.2/