summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2003-10-27 22:33:01 +0000
committerBryan Østergaard <kloeri@gentoo.org>2003-10-27 22:33:01 +0000
commitc8a59922a6401a3ece35a92bd95e52a03822abcf (patch)
treee0a183178e81a61d39abc7d3fa270fb357edfe39 /dev-python/mod_python
parentFixes compilation when using Python-2.3. Closes bug #32018. (diff)
downloadhistorical-c8a59922a6401a3ece35a92bd95e52a03822abcf.tar.gz
historical-c8a59922a6401a3ece35a92bd95e52a03822abcf.tar.bz2
historical-c8a59922a6401a3ece35a92bd95e52a03822abcf.zip
Fixes compilation when using Python-2.3. Closes bug #32018.
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/Manifest2
-rw-r--r--dev-python/mod_python/mod_python-3.0.3.ebuild7
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/mod_python/Manifest b/dev-python/mod_python/Manifest
index f11c9087a4f3..d3884d4a84a1 100644
--- a/dev-python/mod_python/Manifest
+++ b/dev-python/mod_python/Manifest
@@ -1,6 +1,6 @@
MD5 e1b86e5574bcdb91f2574b467320fd89 mod_python-2.7.8.ebuild 2482
MD5 fa728080467e8c1a3d9088d8c7c464aa mod_python-3.0.1.ebuild 1500
-MD5 77740e38bdfa5259d3bf7ebeb3f3dffc mod_python-3.0.3.ebuild 1662
+MD5 8eb50a376a4dbafa813f18fc331b3736 mod_python-3.0.3.ebuild 1658
MD5 e6039ff687a76cda2fd081aabadb396b ChangeLog 1301
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 559839f2f486ddf971d9a9a551721e91 mod_python-3.0.0_beta4.ebuild 1576
diff --git a/dev-python/mod_python/mod_python-3.0.3.ebuild b/dev-python/mod_python/mod_python-3.0.3.ebuild
index a1e9e337b0e0..2bbe505630fc 100644
--- a/dev-python/mod_python/mod_python-3.0.3.ebuild
+++ b/dev-python/mod_python/mod_python-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.3.ebuild,v 1.1 2003/10/06 05:23:14 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.3.ebuild,v 1.2 2003/10/27 22:32:49 kloeri Exp $
DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
@@ -17,6 +17,11 @@ src_unpack() {
cd ${S} || die
epatch ${FILESDIR}/${P}-dest1.diff
epatch ${FILESDIR}/${P}-dest2.diff
+
+ # Fix compilation when using python-2.3
+ has_version ">=dev-lang/python-2.3" && \
+ sed -i -e 's:LONG_LONG:PY_LONG_LONG:g' \
+ "${S}/src/requestobject.c"
}
src_compile() {