summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:40:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-06 15:40:07 +0000
commit0c84fdbdfc985fe7781e0eb97bd30390c26e5fe0 (patch)
treec7f06656ecaa5ab31a63799e9a0bcfca589e5074 /dev-python/pastescript
parentUpdate HOMEPAGE and SRC_URI. (diff)
downloadhistorical-0c84fdbdfc985fe7781e0eb97bd30390c26e5fe0.tar.gz
historical-0c84fdbdfc985fe7781e0eb97bd30390c26e5fe0.tar.bz2
historical-0c84fdbdfc985fe7781e0eb97bd30390c26e5fe0.zip
Use $(PYTHON -f) instead of ${python}. Update HOMEPAGE and SRC_URI.
Package-Manager: portage-15324-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/pastescript-1.7.3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/pastescript/pastescript-1.7.3.ebuild b/dev-python/pastescript/pastescript-1.7.3.ebuild
index 83b1268792e1..e3a85c6477fc 100644
--- a/dev-python/pastescript/pastescript-1.7.3.ebuild
+++ b/dev-python/pastescript/pastescript-1.7.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.3 2009/10/11 08:28:57 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.4 2010/02/06 15:40:07 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -11,8 +12,8 @@ MY_PN="PasteScript"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
-HOMEPAGE="http://pythonpaste.org/script/"
-SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://pythonpaste.org/script/ http://pypi.python.org/pypi/PasteScript"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -39,7 +40,7 @@ src_compile() {
distutils_src_compile
if use doc; then
einfo "Generating docs as requested..."
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
+ PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "generating docs failed"
fi
}