summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-26 10:13:45 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-26 10:13:45 +0000
commit1431743261f1f9afa48c94c64eef41d9a8a47e62 (patch)
treef7d2f197ff6305c6a34f0b99d3b61444b8d82d6a /dev-python/prettytable/prettytable-0.7.2.ebuild
parentSimplify example install code, from https://github.com/gentoo/gentoo-portage-... (diff)
downloadhistorical-1431743261f1f9afa48c94c64eef41d9a8a47e62.tar.gz
historical-1431743261f1f9afa48c94c64eef41d9a8a47e62.tar.bz2
historical-1431743261f1f9afa48c94c64eef41d9a8a47e62.zip
Version Bump; drop old
Package-Manager: portage-2.2.20/cvs/Linux x86_64 Manifest-Sign-Key: 0xE9402A79B03529A2!
Diffstat (limited to 'dev-python/prettytable/prettytable-0.7.2.ebuild')
-rw-r--r--dev-python/prettytable/prettytable-0.7.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/prettytable/prettytable-0.7.2.ebuild b/dev-python/prettytable/prettytable-0.7.2.ebuild
new file mode 100644
index 000000000000..3191533a53ed
--- /dev/null
+++ b/dev-python/prettytable/prettytable-0.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/prettytable/prettytable-0.7.2.ebuild,v 1.1 2015/05/26 10:13:44 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="https://code.google.com/p/prettytable/"
+SRC_URI="mirror://pypi/P/PrettyTable/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" prettytable_test.py || die "tests failed under ${EPYTHON}"
+}