summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Lipelis <aeoo@gentoo.org>2002-01-29 13:40:15 +0000
committerLeo Lipelis <aeoo@gentoo.org>2002-01-29 13:40:15 +0000
commitb30881754cf7f868ccedde1c00e12054d0c76c08 (patch)
tree1ad205cc87c3b70debb6ac1b252660970c8f0e69 /dev-python/psycopg
parentmasking psycopg-1.0.1 for testing (diff)
downloadhistorical-b30881754cf7f868ccedde1c00e12054d0c76c08.tar.gz
historical-b30881754cf7f868ccedde1c00e12054d0c76c08.tar.bz2
historical-b30881754cf7f868ccedde1c00e12054d0c76c08.zip
initial psycopg commit
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/files/digest-psycopg-1.0.11
-rw-r--r--dev-python/psycopg/psycopg-1.0.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/psycopg/files/digest-psycopg-1.0.1 b/dev-python/psycopg/files/digest-psycopg-1.0.1
new file mode 100644
index 000000000000..8a8a589fcdb3
--- /dev/null
+++ b/dev-python/psycopg/files/digest-psycopg-1.0.1
@@ -0,0 +1 @@
+MD5 234075b3d63731b84ddec245279738bf psycopg-1.0.1.tar.gz 172032
diff --git a/dev-python/psycopg/psycopg-1.0.1.ebuild b/dev-python/psycopg/psycopg-1.0.1.ebuild
new file mode 100644
index 000000000000..2babfa04672d
--- /dev/null
+++ b/dev-python/psycopg/psycopg-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Leo Lipelis <aeoo@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.11 2001/12/06 22:12:34 drobbins Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="PostgreSQL database adapter for the Python" # best one
+
+SRC_URI="http://initd.org/pub/software/psycopg/${P}.tar.gz"
+
+HOMEPAGE="http://www.initd.org/software/psycopg.py"
+
+DEPEND="
+ >=dev-lang/python-2.0
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-db/postgresql-7.1.3"
+
+src_compile() {
+ ./configure \
+ --with-mxdatetime-includes=/usr/lib/python2.2/site-packages/mx/DateTime/mxDateTime \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ cd ${S}
+ [ -f "Makefile.orig" ] && die
+ mv Makefile Makefile.orig
+ cat Makefile.orig | sed \
+ -e 's:\(echo " install -m 555 $$mod \)\($(PY_MOD_DIR)\)\("; \\\):\1${D}\2/$$mod\3:' \
+ -e 's:\($(INSTALL) -m 555 $$mod \)\($(PY_MOD_DIR)\)\(; \\\):\1${D}\2/$$mod\3:' > Makefile
+ make install || die
+}