summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2005-08-21 17:23:00 +0000
committerFernando Serboncini <fserb@gentoo.org>2005-08-21 17:23:00 +0000
commit2d700f1d6587080f5eb8a4a48d68a8416d1b9212 (patch)
tree65bc40c74f2c1fc148474d2294b3b4895ed47e56 /dev-python/pygame/pygame-1.7.1.ebuild
parentHousekeeping (diff)
downloadhistorical-2d700f1d6587080f5eb8a4a48d68a8416d1b9212.tar.gz
historical-2d700f1d6587080f5eb8a4a48d68a8416d1b9212.tar.bz2
historical-2d700f1d6587080f5eb8a4a48d68a8416d1b9212.zip
1.7.1 version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-python/pygame/pygame-1.7.1.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.7.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.7.1.ebuild b/dev-python/pygame/pygame-1.7.1.ebuild
new file mode 100644
index 000000000000..3196150ce655
--- /dev/null
+++ b/dev-python/pygame/pygame-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1.ebuild,v 1.1 2005/08/21 17:23:00 fserb Exp $
+
+inherit distutils
+
+MY_P="${PN}-${PV}release"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+HOMEPAGE="http://www.pygame.org/"
+SRC_URI="http://www.pygame.org/ftp/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/numeric-22.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+src_install() {
+ mydoc=WHATSNEW
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+ fi
+}