summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-27 20:41:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-27 20:41:43 +0000
commite2b77992f0cbd5f9d5d7300444c97fba493ed239 (patch)
tree9d4bc4940cafc27804a5393696284ac278e076aa /dev-python/pygobject/files
parentVersion bump (diff)
downloadhistorical-e2b77992f0cbd5f9d5d7300444c97fba493ed239.tar.gz
historical-e2b77992f0cbd5f9d5d7300444c97fba493ed239.tar.bz2
historical-e2b77992f0cbd5f9d5d7300444c97fba493ed239.zip
Fix tests.
Package-Manager: portage-13851-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pygobject/files')
-rw-r--r--dev-python/pygobject/files/pygobject-2.18.0-make_check.patch33
1 files changed, 30 insertions, 3 deletions
diff --git a/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch b/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch
index 14ef14b05483..f351092b2f80 100644
--- a/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch
+++ b/dev-python/pygobject/files/pygobject-2.18.0-make_check.patch
@@ -1,6 +1,5 @@
-diff -ur pygobject-2.18.0.orig/tests/Makefile.am pygobject-2.18.0/tests/Makefile.am
---- pygobject-2.18.0.orig/tests/Makefile.am 2009-05-14 00:56:45.000000000 +0300
-+++ pygobject-2.18.0/tests/Makefile.am 2009-07-24 18:35:13.000000000 +0300
+--- tests/Makefile.am
++++ tests/Makefile.am
@@ -11,7 +11,7 @@
test-thread.h \
test-unknown.h
@@ -28,3 +27,31 @@ diff -ur pygobject-2.18.0.orig/tests/Makefile.am pygobject-2.18.0/tests/Makefile
-.la.so:
- $(LN_S) .libs/$@ $@ || true
+ rm -f .libs/testhelper.so
+--- tests/runtests.py
++++ tests/runtests.py
+@@ -6,6 +6,9 @@
+
+ import common
+
++# Some tests fail with translated messages.
++os.environ["LC_ALL"] = "C"
++
+ program = None
+ if len(sys.argv) == 3:
+ buildDir = sys.argv[1]
+--- tests/test_gio.py
++++ tests/test_gio.py
+@@ -386,9 +386,10 @@
+
+ def testQueryWritableNamespaces(self):
+ infolist = self.file.query_writable_namespaces()
+- for info in infolist:
+- if info.name == "xattr":
+- self.assertEqual(info.type, gio.FILE_ATTRIBUTE_TYPE_STRING)
++ if infolist:
++ for info in infolist:
++ if info.name == "xattr":
++ self.assertEqual(info.type, gio.FILE_ATTRIBUTE_TYPE_STRING)
+
+ def testSetAttribute(self):
+ self._f.write("testing attributes")