summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-12-30 00:20:41 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-12-30 00:20:41 +0000
commit19ebdc2e0dfff5d1bfe1586fff52490a84254fda (patch)
treebbb4931eb7842640eef49c9af791f847dc9107b3 /dev-python/pyode/pyode-1.0.0.ebuild
parentRemove global BASH_COMPLETION_NAME var (diff)
downloadhistorical-19ebdc2e0dfff5d1bfe1586fff52490a84254fda.tar.gz
historical-19ebdc2e0dfff5d1bfe1586fff52490a84254fda.tar.bz2
historical-19ebdc2e0dfff5d1bfe1586fff52490a84254fda.zip
Initial import. Ebuild submitted by Daniel Holth <dholth@fastmail.fm>.
Diffstat (limited to 'dev-python/pyode/pyode-1.0.0.ebuild')
-rw-r--r--dev-python/pyode/pyode-1.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyode/pyode-1.0.0.ebuild b/dev-python/pyode/pyode-1.0.0.ebuild
new file mode 100644
index 000000000000..25a22bf5f3ee
--- /dev/null
+++ b/dev-python/pyode/pyode-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyode/pyode-1.0.0.ebuild,v 1.1 2004/12/30 00:20:41 kloeri Exp $
+
+inherit distutils
+
+MY_P="${P/pyode/PyODE}"
+DESCRIPTION="python bindings to the ode physics engine"
+HOMEPAGE="http://pyode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyode/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/python
+ >=dev-games/ode-0.5
+ >=dev-python/pyrex-0.9.3"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/odepath.patch"
+}