summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 03:07:41 +0000
commitb8b644f00bc7611c48c7305c5c77c759b6116a2d (patch)
tree3e8776152eaf000f1f0824aec7c6e9e5e464fb7e /dev-python/pyqwt/pyqwt-5.2.0.ebuild
parentVersion bump. Fix dependencies (bug #303317). (diff)
downloadhistorical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.tar.gz
historical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.tar.bz2
historical-b8b644f00bc7611c48c7305c5c77c759b6116a2d.zip
Set SUPPORT_PYTHON_ABIS. Require >=dev-python/PyQt4-4.6.1 to avoid file collision (bug #303673). Delete unused "debug" USE flag.
Package-Manager: portage-15325-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pyqwt/pyqwt-5.2.0.ebuild')
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0.ebuild47
1 files changed, 26 insertions, 21 deletions
diff --git a/dev-python/pyqwt/pyqwt-5.2.0.ebuild b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
index 403e926e93ba..38f2c567eedc 100644
--- a/dev-python/pyqwt/pyqwt-5.2.0.ebuild
+++ b/dev-python/pyqwt/pyqwt-5.2.0.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.3 2010/01/31 07:39:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyqwt/pyqwt-5.2.0.ebuild,v 1.4 2010/02/07 03:07:41 arfrever Exp $
-EAPI=2
+EAPI="2"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
-inherit python flag-o-matic
+inherit flag-o-matic python
MY_P="PyQwt-${PV}"
DESCRIPTION="Python bindings for the Qwt library"
@@ -14,38 +17,40 @@ HOMEPAGE="http://pyqwt.sourceforge.net/"
SLOT="5"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="debug doc examples svg"
+IUSE="doc examples svg"
RDEPEND=">=x11-libs/qwt-5.1[svg?]
- dev-python/PyQt4
+ >=dev-python/PyQt4-4.6.1
dev-python/numpy"
DEPEND="${DEPEND}
dev-python/sip"
-
-RESTRICT_PYTHON_ABIS="2.4 2.7 3.*"
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}/configure"
+pkg_setup() {
+ append-flags -fPIC
+}
+
src_configure() {
+ configuration() {
+ # '-j' option can be buggy.
+ "$(PYTHON)" configure.py \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt || return 1
- append-flags -fPIC
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_execute_function -s configuration
- # the -j option can be buggy
- python_version
- "${python}" configure.py \
- --disable-numarray \
- --disable-numeric \
- -I/usr/include/qwt5 \
- -lqwt \
- || die "python configure.py failed"
-
- # avoiding strip the libraries
- sed -i -e '/strip/d' {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
}
src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_src_install
+
cd ..
dodoc ANNOUNCEMENT-${PV} README
if use doc; then