summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 23:42:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-26 23:42:55 +0000
commit6de1dde809d57b7d4cce6ef8f97ceff3eb7d4330 (patch)
tree5cab60a03f8a8200c00de96e8717621b40c3f844 /dev-python/pysnmp/pysnmp-4.1.16a.ebuild
parentVersion bump. (diff)
downloadhistorical-6de1dde809d57b7d4cce6ef8f97ceff3eb7d4330.tar.gz
historical-6de1dde809d57b7d4cce6ef8f97ceff3eb7d4330.tar.bz2
historical-6de1dde809d57b7d4cce6ef8f97ceff3eb7d4330.zip
Version bump.
Package-Manager: portage-2.2.0_alpha28_p35/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pysnmp/pysnmp-4.1.16a.ebuild')
-rw-r--r--dev-python/pysnmp/pysnmp-4.1.16a.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pysnmp/pysnmp-4.1.16a.ebuild b/dev-python/pysnmp/pysnmp-4.1.16a.ebuild
new file mode 100644
index 000000000000..48a184de8013
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-4.1.16a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysnmp/pysnmp-4.1.16a.ebuild,v 1.1 2011/03/26 23:42:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="SNMP library"
+HOMEPAGE="http://pysnmp.sf.net/ http://pypi.python.org/pypi/pysnmp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/pyasn1-0.0.13a
+ dev-python/pycrypto"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="CHANGES README THANKS TODO"
+
+src_install(){
+ distutils_src_install
+
+ dohtml docs/*.{html,gif} || die "dohtml failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples docs/mibs || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog
+ elog "You may also be interested in the following packages: "
+ elog "dev-python/pysnmp-apps - example programs using pysnmp"
+ elog "dev-python/pysnmp-mibs - IETF and other mibs"
+ elog "net-libs/libsmi - to dump MIBs in python format"
+ elog
+}