summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-06 12:40:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-06 12:40:47 +0000
commitb19a8d5fad2f6e66af0e8f7f4dd1ce970401d184 (patch)
treec1b41cd4b4556cf827089cd8f150974edc9107a7 /dev-python/qpid-python/qpid-python-0.20.ebuild
parentVersion bump with kind permission from johu (diff)
downloadhistorical-b19a8d5fad2f6e66af0e8f7f4dd1ce970401d184.tar.gz
historical-b19a8d5fad2f6e66af0e8f7f4dd1ce970401d184.tar.bz2
historical-b19a8d5fad2f6e66af0e8f7f4dd1ce970401d184.zip
add required dep for doc build, improve doc install
Package-Manager: portage-2.2.0/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/qpid-python/qpid-python-0.20.ebuild')
-rw-r--r--dev-python/qpid-python/qpid-python-0.20.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/qpid-python/qpid-python-0.20.ebuild b/dev-python/qpid-python/qpid-python-0.20.ebuild
index c976c3e09ee5..d4e52ea63d5a 100644
--- a/dev-python/qpid-python/qpid-python-0.20.ebuild
+++ b/dev-python/qpid-python/qpid-python-0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qpid-python/qpid-python-0.20.ebuild,v 1.1 2013/11/14 00:44:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qpid-python/qpid-python-0.20.ebuild,v 1.2 2013/12/06 12:40:22 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -17,7 +17,8 @@ LICENSE="MIT"
SLOT="0"
RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
python_compile_all() {
use doc && "${PYTHON}" setup.py doc_option
@@ -38,7 +39,7 @@ src_test() {
}
python_install_all() {
- local HTML_DOCS=( ../"${P}"-python2_7/doc/. )
+ use doc && local HTML_DOCS=( ../"${P}"-python2_7/doc/. )
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}